Update 5.0i

What's hot...

Moderator: Mattk

Post Reply
User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 4971
Joined: Mon Oct 01, 2007 10:51 pm

Update 5.0i

Post by admin » Sun Mar 15, 2015 8:36 pm

Update to Meteohub V5.0i (NSLU2, x86, SheevaPlug, RPI) brings these features:
  • adds experimental support for Oregon WMR-300 station. Historical data of the logger inside the station is not used. Implementation is based on sniffing the USB data, so there might still be a few bugs in there. Data from wind, rain, indoor and outdoor temp sensors are obviously received fine.
Update Link: http://www.meteohub.de/files/update-v5.0i.upd

Update Link (NSLU2 only): http://www.meteohub.de/files/update-nslu2-v5.0i.upd

HWTest
Expert Boarder
Expert Boarder
Posts: 92
Joined: Fri Apr 09, 2010 8:25 pm

Re: Update 5.0i

Post by HWTest » Wed Apr 29, 2015 9:03 pm

Today I noticed a strange error, when I was investigating, why I don't get emails from MeteoHub even when sensors are failing.
When I click on the "save & test" button in the e-mail setup I get this:

Mail send failed: /opt/sbin/sendmail: error while loading shared libraries: libidn.so.11: cannot open shared object file: No such file or directory

I have also tried this: "moves away from outdated "esmtp" also on Sheevaplug (and iConnect) platforms. "msmtp" is now used instead. It does need you to press "save" on email section of "push services" page in order to have your credentials transformed to the way "msmtp" is expecting them."

I'm running MeteoHub 5.0i (Build 1592) on a Silverstone DC01. I don't remember the last time I got an email from MeteoHub so I don't know, when it stopped working.

Edit: Another thing I've noticed is, that during backup (rsync) I get this error message: "/msmtprc" (in config): Permission denied (13). I think it's connected with the mail send problem. When I change permissions of the file from 600 to 644, the backup is successfull but the next day the problem is back and the permissions are back to 600.

HWTest
Expert Boarder
Expert Boarder
Posts: 92
Joined: Fri Apr 09, 2010 8:25 pm

Re: Update 5.0i

Post by HWTest » Thu May 07, 2015 4:38 pm

It seems there are some unmet dependencies, the fix for this problem is:

Code: Select all

apt-get update
apt-get -f install
You are doing it on your own risk!

Post Reply