Update 4.9f

What's hot...

Moderator: Mattk

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5024
Joined: Mon Oct 01, 2007 10:51 pm

Re: Update 4.9f

Post by admin » Fri Apr 06, 2012 2:49 pm

I fixed it. You can close the ports again.

User avatar
idociko
Junior Boarder
Junior Boarder
Posts: 39
Joined: Tue Jan 24, 2012 6:16 pm
Location: Cikó, Hungary
Contact:

Re: Update 4.9f

Post by idociko » Fri Apr 06, 2012 3:19 pm

Thanks a lot! Have a nice eastern!

User avatar
YJB
Platinum Boarder
Platinum Boarder
Posts: 385
Joined: Thu Feb 19, 2009 5:53 pm
Location: Venhuizen, Netherlands
Contact:

Re: Update 4.9f

Post by YJB » Fri Apr 06, 2012 9:25 pm

YJB wrote:
logger (05.04.2012 20:25:42): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
...
...
logger (06.04.2012 00:14:37): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
logger (06.04.2012 00:14:51): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
wmr928fulleval(06.04.2012 03:44:29): recomputation of weather data finished: 48792227 records processed in 47316 seconds (1031 records per second)
wmr928fulleval(06.04.2012 03:45:02): recomputation of weather data started.

I assume that this is related to the new windchill calculation, I did change my temp sensor from th0 to th4

The recomputation started automatically again right after it was finished.
Quick update: the second recomputation finished without any errors, not sure what happened.

Code: Select all

wmr928fulleval(06.04.2012 03:45:02): recomputation of weather data started.
wmr928fulleval(06.04.2012 18:00:10): recomputation of weather data finished: 48823341 records processed in 51252 seconds (952 records per second)

User avatar
YJB
Platinum Boarder
Platinum Boarder
Posts: 385
Joined: Thu Feb 19, 2009 5:53 pm
Location: Venhuizen, Netherlands
Contact:

Re: Update 4.9f

Post by YJB » Sat Apr 07, 2012 8:21 am

Hmm, I'm get another 50 messages or so saying that MH is not happy:

Code: Select all

logger (06.04.2012 22:19:43): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
logger (06.04.2012 22:19:57): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
logger (06.04.2012 22:20:25): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
logger (06.04.2012 22:20:53): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
logger (06.04.2012 22:21:07): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
logger (06.04.2012 22:21:07): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
...
...
logger (07.04.2012 00:14:17): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
logger (07.04.2012 00:14:31): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
logger (07.04.2012 00:14:45): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
logger (07.04.2012 00:14:59): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
There is no recomputation running, so it's not related to that.

Not sure if it has to do with my Vantage dropping out:

Code: Select all

logger (06.04.2012 22:10:17): data logger stopped.
logger (06.04.2012 22:10:22): data logger (version 4.9f, build 6304) started.
logger (06.04.2012 22:10:23): connect station 0 (RFXCOM via USB serial).
logger (06.04.2012 22:10:23): connect station 1 (Vantage via TCP/IP).
logger (06.04.2012 22:10:23): connect station 2 (System Data via Plug-in).
logger (06.04.2012 22:10:23): station 1 (Vantage), wakeup sent.
logger (06.04.2012 22:10:23): station 1 (Vantage), internal logger activated.
logger (06.04.2012 22:10:23): station 1 (Vantage), syncing.
logger (06.04.2012 22:10:36): station 1 (Vantage), gettime request sent.
logger (06.04.2012 22:10:46): station 1 (Vantage), gettime request sent.
logger (06.04.2012 22:10:57): station 1 (Vantage), gettime request sent.
logger (06.04.2012 22:10:57): station 1 (Vantage), time offset of Vantage: -28 minutes
logger (06.04.2012 22:10:57): station 1 (Vantage), eeprom request sent.
logger (06.04.2012 22:10:58): station 1 (Vantage), rain collector size 0.2 mm per tick.
logger (06.04.2012 22:10:58): station 1 (Vantage), transmitter 1 active as station type (#0) "ISS".
logger (06.04.2012 22:10:58): station 1 (Vantage), transmitter 2 active as station type (#4) "Wireless Anemometer".
logger (06.04.2012 22:10:58): station 1 (Vantage), no reading of Vantage's internal logger as data gap is less than 10 minutes: 557 secs
But then, why does it continue logging these messages for almost 2 hours?

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5024
Joined: Mon Oct 01, 2007 10:51 pm

Re: Update 4.9f

Post by admin » Sat Apr 07, 2012 8:44 am

Can you reproduce the error messages when restarting the logger? If so I would like to have a closer look at your Meteohub via ports 7777 and 22.

User avatar
YJB
Platinum Boarder
Platinum Boarder
Posts: 385
Joined: Thu Feb 19, 2009 5:53 pm
Location: Venhuizen, Netherlands
Contact:

Re: Update 4.9f

Post by YJB » Sat Apr 07, 2012 10:26 am

Yes!

Code: Select all

logger (07.04.2012 10:01:37): station 1 (Vantage), rain collector size 0.2 mm per tick.
logger (07.04.2012 10:01:37): station 1 (Vantage), transmitter 1 active as station type (#0) "ISS".
logger (07.04.2012 10:01:37): station 1 (Vantage), transmitter 2 active as station type (#4) "Wireless Anemometer".
logger (07.04.2012 10:01:37): station 1 (Vantage), no reading of Vantage's internal logger as data gap is less than 10 minutes: 75 secs
logger (07.04.2012 10:09:32): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
logger (07.04.2012 10:09:46): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
logger (07.04.2012 10:10:14): Bad wind3804496 sensor data, "chill x10" (-999) out of range [-700:1500]
It starts some 8 minutes after restarting the logger. I'll mail you access details

marti
Fresh Boarder
Fresh Boarder
Posts: 13
Joined: Sat Nov 26, 2011 11:22 am
Contact:

Re: Update 4.9f

Post by marti » Sat Apr 07, 2012 8:04 pm

Hi Boris,

Please, can you made a correct coding for Estonian fc! Now WD-live can't show our öäõü letters!

Thanks!

Marti

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5024
Joined: Mon Oct 01, 2007 10:51 pm

Re: Update 4.9f

Post by admin » Sat Apr 07, 2012 11:16 pm

Sorry, but this whole language adaption thing for WD-Live (which is not my product) looks like a never ending story with close to zero benefit. When you send me data in the correct encoding I will implement it. So it is up to you to decide, if YOU are willing to put effort into this.

marti
Fresh Boarder
Fresh Boarder
Posts: 13
Joined: Sat Nov 26, 2011 11:22 am
Contact:

Re: Update 4.9f

Post by marti » Sat Apr 07, 2012 11:45 pm

YES, i try!

BR,

Marti


admin wrote:Sorry, but this whole language adaption thing for WD-Live (which is not my product) looks like a never ending story with close to zero benefit. When you send me data in the correct encoding I will implement it. So it is up to you to decide, if YOU are willing to put effort into this.
Attachments
ilmaennustus_ETWDL.rar
(916 Bytes) Downloaded 168 times

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5024
Joined: Mon Oct 01, 2007 10:51 pm

Re: Update 4.9f

Post by admin » Mon Apr 09, 2012 11:40 am

Next version will have a "individual" feature, so you will not need my support in punching out vantage forcast texts in any language you like and you will no longer have to bother with my unwillingless to fight these special character things ;-)

Cite from update plan:
WD-Live receives forecast texts in English, German, Italian and Dutch from inside Meteohub. Selection of forecast language is now done by a separate drop-down box on "WD-Live" page of Meteohub. When language "individual" is choosen the texts from "/data/graphs/individualfc.txt" (resp. "/public/graphs/individualfc.txt" when you access it as a pc-network drive) are used. This allows you to feed WD-Live with Vantage forecast text of any langage. Format of "individualfc.txt" is a flat file, each line holding a forecast message. If file is not there or there is no line for the given forecast number, a dash will be reported as message. Individual forecast text is also reported in variable "actual_thb?_fc_textindividual".

User avatar
wvdkuil
Platinum Boarder
Platinum Boarder
Posts: 328
Joined: Sun Jul 24, 2011 8:00 pm
Location: Belgium
Contact:

Re: Update 4.9f

Post by wvdkuil » Mon Apr 09, 2012 1:27 pm

Very good idea to handle the translations in this way.
You wrote:
--- Format of "individualfc.txt" is a flat file, each line holding a forecast message. If file is not there or there is no line for the given forecast number ----

Question 1: Can you already post the list of the forecast numbers and corresponding english text?
Question 2: Are those numbers the same as the actual_thb?_fc_rule ?

I'm developing (for first release in june this year) a template set which supports amongst others multi language support.
The first release supports VP forecasts in English Dutch French and German.

Meteohubs output:
actual_thb0_fc_rule 192
actual_thb0_fc_text Mostly_cloudy_and_cooler._Precipitation_possible_within_12_hours,_possibly_heavy_at_times._Windy.

I translate by exploding the fc_text (=english) to obtain the individual forecast parts. I then translate them separately and combine them again to get the total forecast.
I am not aware of a list of the individual parts so i am not sure i got all possible forecasts.

Keep up the good work.

Wim van der Kuil
www.weerstation-leuven.be for testing the template set.
www.weerstation-herent.be and www.weerstation-wilsele.be for "production" versions of the template set.

marti
Fresh Boarder
Fresh Boarder
Posts: 13
Joined: Sat Nov 26, 2011 11:22 am
Contact:

Re: Update 4.9f

Post by marti » Mon Apr 09, 2012 1:48 pm

Very good idea, thank you 8)

BR,

Marti
admin wrote:Next version will have a "individual" feature, so you will not need my support in punching out vantage forcast texts in any language you like and you will no longer have to bother with my unwillingless to fight these special character things ;-)

marti
Fresh Boarder
Fresh Boarder
Posts: 13
Joined: Sat Nov 26, 2011 11:22 am
Contact:

Re: Update 4.9f

Post by marti » Mon Apr 09, 2012 1:52 pm

You found English fc text: viewtopic.php?f=18&t=8104#p10054

BR,
Marti
wvdkuil wrote:Question 1: Can you already post the list of the forecast numbers and corresponding english text?

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5024
Joined: Mon Oct 01, 2007 10:51 pm

Re: Update 4.9f

Post by admin » Mon Apr 09, 2012 2:39 pm

Question 1: Can you already post the list of the forecast numbers and corresponding english text?
Yes, the list linked above can be taken as a starting point for translation. Please just provide the plain texts, one in each line, no quotation marks, no line numbers.
Question 2: Are those numbers the same as the actual_thb?_fc_rule?
Yes, the number provided as "actual_thb?_fc_rule" will be used as an index (0=first lines, 1 = second line, ...) to the lines in the individual text file.

markhiseman
Senior Boarder
Senior Boarder
Posts: 61
Joined: Wed Nov 05, 2008 4:25 pm
Location: Maidstone, Kent, UK
Contact:

Re: Update 4.9f

Post by markhiseman » Tue Apr 10, 2012 8:27 pm

I just updated to 4.9f. Meteohub no longer receives a reading from the WTGR800 wind sensor on my WMR-100 station. Ther WMR-100 is receiving from the WTGR800 OK, but Meteohub says 'never' received on the sensors page. All the other WMR-100 sensors are being received OK by Meteohub.

I have tried rebooting both Meteohub and the WMR-100 with no luck. It was working fine until I updated to 4.9f.

Any ideas?

Mark.

Post Reply