Evaluation version - WDL upload frequency? - [Solved]

Moderator: Mattk

gm4jjj
Expert Boarder
Expert Boarder
Posts: 108
Joined: Mon Jan 18, 2010 3:53 pm
Location: Dunfermline, Fife UK

Re:Evaluation version - WDL upload frequency?

Post by gm4jjj » Thu Jan 28, 2010 12:27 am

admin wrote:could you please try to run this statement in your ssh shell? It is a test if the recognition whether a process is already running works ok on your rig.

Code: Select all

[ -n "`/bin/pidof /home/meteohub/meteoschedule`" ] || echo "found"
As meteoschedule should be running (please check with "ps ax" ) the statement above should return "found".
I tried this and do not get return, though meteoschedule is running.

Code: Select all

meteohub:~# ps ax
  PID TTY      STAT   TIME COMMAND
    1 ?        Ss     0:03 init [2]  
    2 ?        S<     0:00 [kthreadd]
    3 ?        S<     0:00 [ksoftirqd/0]
    4 ?        S<     0:00 [watchdog/0]
    5 ?        S<     0:04 [events/0]
    6 ?        S<     0:00 [khelper]
   41 ?        S<     0:00 [kblockd/0]
   44 ?        S<     0:00 [kacpid]
   45 ?        S<     0:00 [kacpi_notify]
  105 ?        S<     0:00 [kseriod]
  137 ?        S      0:00 [pdflush]
  138 ?        S      0:00 [pdflush]
  139 ?        S<     0:00 [kswapd0]
  140 ?        S<     0:00 [aio/0]
  565 ?        S<     0:00 [ksuspend_usbd]
  572 ?        S<     0:00 [khubd]
  574 ?        S<     0:00 [ata/0]
  590 ?        S<     0:00 [ata_aux]
  872 ?        S<     0:00 [kjournald]
 1023 ?        S<s    0:00 udevd --daemon
 1327 ?        S<     0:00 [kpsmoused]
 1573 ?        S<     0:00 [ksnapd]
 1601 ?        S<     0:02 [kjournald]
 1720 ?        Ss     0:00 /sbin/portmap
 1959 ?        S      0:00 /home/meteohub/meteoschedule /dev/meteohub
 2002 ?        Ss     0:04 /sbin/syslogd
 2008 ?        Ss     0:00 /sbin/klogd -x
 2081 ?        Ss     0:00 /usr/sbin/acpid -c /etc/acpi/events -s /var/run/acpid
 2086 ?        S<s    0:00 /home/meteohub/loggerd /var/run/loggerd.pid
 2087 ?        S<     0:26 /home/meteohub/loggerd /var/run/loggerd.pid
 2093 ?        Ss     0:39 /home/meteohub/meteonet -r
 2157 ?        Ss     0:00 /usr/bin/rsync /var/run/rsyncd.pid --daemon
 2158 ?        S<    11:08 /home/meteohub/hidlog2 2 4130822658113
 2160 ?        Z<     0:00 [sh] <defunct>
 2173 ?        Ss     0:01 /usr/sbin/nmbd -D
 2175 ?        Ss     0:00 /usr/sbin/smbd -D
 2184 ?        S      0:00 /usr/sbin/smbd -D
 2188 ?        Ss     0:00 /usr/sbin/sshd
 2191 ?        S<s    0:02 /usr/sbin/thttpd -C /etc/thttpd.conf
 2193 ?        S<s    0:02 /usr/sbin/thttpdbackup -C /etc/thttpd-backup.conf
 2228 ?        Ss     0:00 /sbin/rpc.statd
 2243 ?        Ss     0:09 /usr/sbin/ntpd -p /var/run/ntpd.pid -g
 2253 ?        Ss     0:05 /usr/sbin/cron
 2261 ?        SLs    0:06 /usr/sbin/watchdog
 2294 tty1     Ss+    0:00 /sbin/getty 38400 tty1
 2295 tty2     Ss+    0:00 /sbin/getty 38400 tty2
 2297 tty3     Ss+    0:00 /sbin/getty 38400 tty3
 2300 tty4     Ss+    0:00 /sbin/getty 38400 tty4
 2301 tty5     Ss+    0:00 /sbin/getty 38400 tty5
 2303 tty6     Ss+    0:00 /sbin/getty 38400 tty6
 2722 ?        Rs     0:00 sshd: root@pts/0 
 2729 pts/0    Ss     0:00 -bash
 2911 ?        Z      0:00 [watchdog] <defunct>
 2912 pts/0    R+     0:00 ps ax
meteohub:~# [ -n "`/bin/pidof /home/meteohub/meteoschedule`" ] || echo "found"
meteohub:~# 
Details here, I am running Ubuntu 9.10 NBR as host system and the Meteohub Virtual in VM Player 3 inside that, so I have not really ported it as such, just running your VM.

I would love to be able it run it natively in Ubuntu 9.10 someday as I feel the VM may be problematic.

After an automatic reboot of meteohub at 01:00, there have not been any problems with it today 21.5 hours later.

I wonder if the cron might be getting confused when NTP steps the time by a fraction of second. This happens quite a lot in the VM.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5026
Joined: Mon Oct 01, 2007 10:51 pm

Re:Evaluation version - WDL upload frequency?

Post by admin » Thu Jan 28, 2010 1:19 am

Please find out why "/bin/pidof /home/meteohub/meteoschedule" does not report the process id of the psecified process.

gm4jjj
Expert Boarder
Expert Boarder
Posts: 108
Joined: Mon Jan 18, 2010 3:53 pm
Location: Dunfermline, Fife UK

Re:Evaluation version - WDL upload frequency?

Post by gm4jjj » Thu Jan 28, 2010 11:06 am

admin wrote:Please find out why "/bin/pidof /home/meteohub/meteoschedule" does not report the process id of the psecified process.

meteohub:~# /bin/pidof /home/meteohub/meteoschedule
1960

I did not understand exactly what your previous -n and || did, but it did not return found, however pidof can tell what the process id is.

The good news is that meteohub continued to run all yesterday without a problem and today also so far.

Question:
Is there any plan to produce meteohub as a direct install into an existing linux system? I would be interested in running it in my Asus Ubuntu 9.10 rather than in Debian inside a VM.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5026
Joined: Mon Oct 01, 2007 10:51 pm

Re:Evaluation version - WDL upload frequency?

Post by admin » Thu Jan 28, 2010 12:52 pm

sorry that doesn't make sense. When a pid is reported statement above will echo "found". could you please check again?

Code: Select all

[ -n 
"`/bin/pidof /home/meteohub/meteoschedule`" ] || echo "found"
Please type in without line breaks and make sure you type the back-quotes right ( ` ).

gm4jjj
Expert Boarder
Expert Boarder
Posts: 108
Joined: Mon Jan 18, 2010 3:53 pm
Location: Dunfermline, Fife UK

Re:Evaluation version - WDL upload frequency?

Post by gm4jjj » Thu Jan 28, 2010 1:02 pm

admin wrote:sorry that doesn't make sense. When a pid is reported statement above will echo "found". could you please check again?

Code: Select all

[ -n 
"`/bin/pidof /home/meteohub/meteoschedule`" ] || echo "found"
Please type in without line breaks and make sure you type the back-quotes right ( ` ).
Well I tried it again, I copied and pasted and it looks right - Is it perhaps echoing on some other screen?

Code: Select all

meteohub:~# [ -n "`/bin/pidof /home/meteohub/meteoschedule`" ] || echo "found" 
meteohub:~# 

If I type echo "test" I do get test back, so echo works, just that -n command does not.

gm4jjj
Expert Boarder
Expert Boarder
Posts: 108
Joined: Mon Jan 18, 2010 3:53 pm
Location: Dunfermline, Fife UK

Re:Evaluation version - WDL upload frequency?

Post by gm4jjj » Sun Jan 31, 2010 2:08 pm

I have not changed anything, but I am happy to report that all is working well for over 2 days now. Perhaps it was some temporary problem with my ISP?

Post Reply