Correct Version? Shivaplug going offline regularly

Moderator: Mattk

Post Reply
andrew02467
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: Tue Apr 10, 2012 6:18 pm

Correct Version? Shivaplug going offline regularly

Post by andrew02467 » Sat May 06, 2017 6:39 pm

My Shivaplug has been rock solid for some years now, but in the last few months it drops off the network. The lights above the ethernet connector on the plug flash as if there's traffic, but I cannot ping nor http to the device and it is not updating info to Weather Underground etc...log entries say only that there is no response from Weather Underground which would indicate some lack of transport/connection (yet from anywhere else on my network I can reach WU fine). Outbound port 80 has never been blocked and I've checked that hasn't changed. Sometimes, but not always, when I ping the Shivaplug from a PC on my network I get maybe a 10% success rate, othertimes 0%.

I have switched out the ethernet cable and the switch to no avail. If I unplug the ethernet connector from the Shivaplug, wait a few secs and re-connect, then I can ping and http successfully, at least until it drops off the network again. I have checked on the router to make sure there is no other IP number duplicating the Shivaplug's...and by the way both the IP number it is using as well as the .77 backup number are both unreachable when these dropouts occur.

It's now running 5.0t but I read that the recent updates seem to be labelled for NSLU platform only...should I have stayed back on 4.9? Could this be the issue? My only other option as far as I can see is to order a new hardware platform..the Shivaplug does seem very warm to the touch...cant' say I remember whether it's been this way before or not.

Thanks for any help/suggestions.

Andrew

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5004
Joined: Mon Oct 01, 2007 10:51 pm

Re: Correct Version? Shivaplug going offline regularly

Post by admin » Sun May 28, 2017 10:05 pm

Sheevaplug is still supported. Recent updates should work fine.
I fear you have a hardware issue, as the Sheeva is since years EOL.

BigAlT
Fresh Boarder
Fresh Boarder
Posts: 8
Joined: Tue Jul 04, 2017 8:41 pm
Location: Washington State

Re: Correct Version? Shivaplug going offline regularly

Post by BigAlT » Thu Jul 13, 2017 8:25 am

I had similar issues with my Sheevaplug. I noticed that my 4GB SD Card ( which was the recommended size and was included with meteohub preinstalled when I purchased it) was full ( after 5 years of data ). I cloned my 4GB Meteohub SD card to a new 8GB SD Card and expanded the data partition to fill all unused space on the 8GB SD card ( using a gparted live CD ). I then had to do a activation key transfer to the new SD card. It's now been working fine ever since.
Your other relatively low priced option is to backup all your data onto your PC as well as save your settings and change hardware to a Rapsberry PI. Download the Meteohub Rapspberry PI version S image and expand it on to at least a 16GB micro SD card. Load your saved data and settings back onto your Radpberry PI and do an activation key transfer. You may also want to change the data storage location from the SD card to a USB thumb drive as described in another post on the Raspberry PI hardware section of this forum as it seems to aleviate many data errors.

andrew02467
Fresh Boarder
Fresh Boarder
Posts: 4
Joined: Tue Apr 10, 2012 6:18 pm

Re: Correct Version? Shivaplug going offline regularly

Post by andrew02467 » Tue Sep 12, 2017 1:28 pm

Wanted to thank you for this info. I did as you said, then also deleted my history more than 2 years ago anyway and the problems were _almost_eliminated. I still had periods when the Shivaplug did not respond to browser attempts to connect and was not sending out updates to the four weather sites I had configured. But after such periods, it did always come back online.

What I did find out by pouring through the logs was that one of the weather spots I was updating to was holding onto the connexion without closing it, and the time-outs on Shivaplug did not seem to be working. When I stopped those updates to that website from going out, I am back to 100% normal.

Post Reply