Page 1 of 1

No sensor data with rfxtrx 433 usb and Meteohub 5.0p

Posted: Tue Aug 16, 2016 12:41 am
by Franky99
Hello...
Im new on Metetohub. I took an Rapberry pi, went trough setup and connected a WS2300 to USB Port and configured sensor data. Everything works perfect with WS2300...

The I took an USB RFXTRX433 (without "E"), conneted it to USB and configurd as Wetaher station hardware. In sensor section I never get sensor data. Sensors are OS WMR 918 temp, baro, hum, wind sensors. Data ist well received when RFXTRX is hooked up with Windows utility or on a domoticz Rasperry server.

just on meteohub, I cannot se sensor data.

Any idea?

Re: No sensor data with rfxtrx 433 usb and Meteohub 5.0p

Posted: Sat Sep 10, 2016 3:46 pm
by darko360
Hi.
Dit you find a solution for the problem?

I'm encountring exact the same problem...
Tried a RPI 2 B and a RPI 1 B. Both the same problem.
With RFXmngr on the laptop, sensor data is popping up every minute.
Tried different firmware on te RFXTRX. Still not working
I also tried Domoticz on the RPI 1 B. No problem there! in Domoticz I've configured the hardware, and within 1 minute the sensors are showing... Strange...?!

I think Meteohub is somehow changing the protocol settings from the rfxtrx, but I have no idea where to find/change these settings.

Re: No sensor data with rfxtrx 433 usb and Meteohub 5.0p

Posted: Sun Sep 11, 2016 12:36 am
by Franky99
Hi Darko,
No, I didn't find any solution. The developper (Boris P.) of Meteohub wrote to me (august 2016), that "he has frozen years ago (!!) pthe development of rfxtrx drivers in Meteohub lack of demand and he cannot help figuring what the problem is".... I think some newer Firmware of RFXTRX is no more suportet by Meteohub :-(
I just cannot understand why rfxtrx is actually still listet as supportet hardware, as indeed it isn't...

I finally I bought another wheater station... Actually the only possibility to connect wireless sensors without a console to meteohub is the Davis Meteostation with a Meteostick or with Meteobridge pro.

Re: No sensor data with rfxtrx 433 usb and Meteohub 5.0p

Posted: Sun Sep 11, 2016 9:30 pm
by rune
Franky99 wrote:Hello...
Im new on Metetohub. I took an Rapberry pi, went trough setup and connected a WS2300 to USB Port and configured sensor data. Everything works perfect with WS2300...

The I took an USB RFXTRX433 (without "E"), conneted it to USB and configurd as Wetaher station hardware. In sensor section I never get sensor data. Sensors are OS WMR 918 temp, baro, hum, wind sensors. Data ist well received when RFXTRX is hooked up with Windows utility or on a domoticz Rasperry server.

just on meteohub, I cannot se sensor data.

Any idea?
Which firmware are you running your RFXtrx with? I'm on 1003 and it's working fine with Meteohub. But if Boris doesn't support new versions then it's very sad news :cry:

Re: No sensor data with rfxtrx 433 usb and Meteohub 5.0p

Posted: Mon Sep 12, 2016 9:10 pm
by darko360
I've tried 1006 and also downgraded tot 1001. Both firmware's didn't work.

Are U also running Meteohub on the Raspberry? And wich Meteohub version?
I've only tried the last, 5.0P, because the previous versions are outdated.

Re: No sensor data with rfxtrx 433 usb and Meteohub 5.0p

Posted: Wed Sep 14, 2016 2:25 pm
by darko360
part of the system log:
Sep 14 14:19:26 meteohub-rpi kernel: [340995.233780] usb 1-1.4: new full-speed USB device number 5 using dwc_otg
Sep 14 14:19:26 meteohub-rpi kernel: [340995.378422] usb 1-1.4: New USB device found, idVendor=0403, idProduct=6001
Sep 14 14:19:26 meteohub-rpi kernel: [340995.385527] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Sep 14 14:19:26 meteohub-rpi kernel: [340995.393030] usb 1-1.4: Product: RFXtrx433
Sep 14 14:19:26 meteohub-rpi kernel: [340995.397632] usb 1-1.4: Manufacturer: RFXCOM
Sep 14 14:19:26 meteohub-rpi kernel: [340995.401990] usb 1-1.4: SerialNumber: A1XH8J6Z
Sep 14 14:19:26 meteohub-rpi kernel: [340995.412654] ftdi_sio 1-1.4:1.0: FTDI USB Serial Device converter detected
Sep 14 14:19:26 meteohub-rpi kernel: [340995.419892] usb 1-1.4: Detected FT232RL
Sep 14 14:19:26 meteohub-rpi kernel: [340995.425372] usb 1-1.4: FTDI USB Serial Device converter now attached to ttyUSB0

part of the meteohub log:
logger (14.09.2016 14:20:41): data logger (version 5.0p, build 176) started.
logger (14.09.2016 14:20:42): station 0 (RFXTRX 433MHz), can't set attributes of device x: Bad file descriptor
logger (14.09.2016 14:20:54): parent process received termination signal (15).
logger (14.09.2016 14:20:54): child process received termination signal (15).
logger (14.09.2016 14:20:55): data logger (version 5.0p, build 176) started.
logger (14.09.2016 14:20:56): connect station 0 (RFXTRX 433MHz via USB serial).

Seems like the Meteohub software does not set or does not read the protocol settings from te RFXTRX.
Any idea?

Re: No sensor data with rfxtrx 433 usb and Meteohub 5.0p

Posted: Wed Sep 14, 2016 8:54 pm
by rune
darko360 wrote:I've tried 1006 and also downgraded tot 1001. Both firmware's didn't work.

Are U also running Meteohub on the Raspberry? And wich Meteohub version?
I've only tried the last, 5.0P, because the previous versions are outdated.
No it's running on a virtualbox. It's running with a converted VMware image. I do have occational USB dropouts, but I'm living with it. I've considered other PWS platforms, but never did anything about it.

Re: No sensor data with rfxtrx 433 usb and Meteohub 5.0p

Posted: Fri Oct 14, 2016 10:03 am
by Armond
I have meteohub 5.0P with RPI and rfxtrxe with fw 251.
It have worked fine, but now I dont have any sensor data.
I reboot the system, but no luck at all.

Re: No sensor data with rfxtrx 433 usb and Meteohub 5.0p

Posted: Tue Jul 04, 2017 9:19 pm
by rune
Sometimes it helps to power everything down.

Re: No sensor data with rfxtrx 433 usb and Meteohub 5.0p

Posted: Tue Jul 25, 2017 11:19 pm
by Armond
Try to delete the weather station and add the weather station again on the "Weather Station" side.
It had worked for me when it suddenly was no sensor data.