Upload of Camera image via FTP to WU Failing

All about the standard Meteobridge devices based on mobile routers from TP-Link, D-Link, ASUS

Moderator: Mattk

Post Reply
K7FZO
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Fri Mar 11, 2016 5:37 pm
Location: North Bend, WA
Contact:

Upload of Camera image via FTP to WU Failing

Post by K7FZO » Fri Mar 11, 2016 9:30 pm

A week ago we started noticing webcam images displayed on our WeatherUnderground page were 2 to 5 hours old.
We found by checking the meteobridge software the following errors:

Weather Underground Cam: 2016-03-11 09:11:28 Error: Could not read reply from control connection -- timed out.
and
System Message
Error: Weather Underground Camera FTP upload failed: Could not read reply from control connection -- timed out. ncftpput _wucam: timed out while waiting for server response.

The FTP upload had failed before but only about 5% of the time, now it fails about 95% of the time.

I emailed WU Support and was told we had everything setup correctly but they were not seeing many upload attempts over a 24 hour period even though we had the meteobridge upload set to every 5 minutes.

I rebooted the meteobridge device recently and received Ver. 2.8 of the firmware. Could this be the cause? It is about the only thing we can think that has changed anywhere on our network, camera software (Ubiquity Camera) or Internet connection.

All other data is moving perfectly to the other weather sites. Any suggestions as to what we should try next?

-Thom / K7FZO

User avatar
D2149
Senior Boarder
Senior Boarder
Posts: 45
Joined: Mon Mar 07, 2016 12:30 am
Location: Bass Lake - California USA (Southern Sierra Nevada near Yosemite National Park)
Contact:

Re: Upload of Camera image via FTP to WU Failing

Post by D2149 » Sat Mar 12, 2016 6:11 am

There were changes made to the FW today related to major upload issues I was having with ALL of my Weather Net sites on my Meteobridge PRO. Boris found a bug in that section of the code and pushed out today's update. Since your issue is related to uploading data, it is possible that something went south when the other issues were fixed.

I am still having intermittent uploading problems with Weather Cloud only now, so there may still be some bugs yet to patch.

Just speculating here of course.

Would sure be nice to have some transmission logs to look at. I feel like I am flying blind here when I get these uploading issues. :(

Post Reply