MB Pro Not Uploading/uploading randomly

All about the cool new device that can read RF data directly from Davis® weather stations

Moderator: Mattk

Post Reply
alriksy
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: Tue May 24, 2016 7:39 pm

MB Pro Not Uploading/uploading randomly

Post by alriksy » Sat Jun 11, 2016 12:32 am

Yesterday, MBPro stopped uploading both to WU and to my webpage (alriksyweather.net). I rebooted and things were working until this morning when the webpage stopped updating. Rebooted again but I noticed that WU was updating at irregular intervals , 2min, 1min, 5min, 1min, 10min, etc.. The live data tab shows updates occurring with past time. For example, MB updates at 14:05 when the real time is 14:34. Updates are occurring at random times on the web page, with large gaps. The time setting in MB is correct, Lat and Long. correct, and the time zone is correct. Any ideas?

alriksy
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: Tue May 24, 2016 7:39 pm

Re: MB Pro Not Uploading/uploading randomly

Post by alriksy » Sat Jun 11, 2016 9:18 pm

I decided to try a direct ethernet connection. After being plugged in overnight, this morning everything is updating on a regular schedule. WU is at 5min, WU rapid-fire about 5 sec, meteotemplate page live gauges at about 5 sec. I do not have a weak wifi signal -58db but for some reason this appears to have been a problem? I even tried a different wifi router but still did not get regular updates. I'm not a network expert, but wonder if inconsistent communication with the router via wifi caused a packet issue and extreme delays or whether MB has a bug in wifi.

I monitored the uploads this morning and once again, after an hour or so, the meteotemplate is not updating regularly but WU is. The server update is now lagging 45min behind the live gauges, but they are slow too. Maybe it isn't an ethernet solution after all. Perhaps MySQL db is not updating because of a server problem? I am new to the forum and MBPro so I hope someone understands this better than I do.

alriksy
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: Tue May 24, 2016 7:39 pm

Re: MB Pro Not Uploading/uploading randomly

Post by alriksy » Sun Jun 12, 2016 8:13 pm

I noticed that just prior to the problem, the system upgraded to 2.9. Last night I went back to 2.8 and disabled automatic updates. The uploads are regular again to WU and the meteotemplate page. I have no idea if this helped or not since, as I wrote earlier, uploads started randomly being received at WU and the template but stopped by early afternoon when 2.9 was installed.

Post Reply