Can't update to 4.9 from 4.7

Moderator: Mattk

Post Reply
ipe
Junior Boarder
Junior Boarder
Posts: 23
Joined: Sun Jul 31, 2011 10:00 am

Can't update to 4.9 from 4.7

Post by ipe » Mon May 28, 2012 8:49 am

Hi,

I can't update to latest version (4.9i) from a new usb stick with version 4.7.

I tried automatically and manually (i.e. /data/transfer/update.new). I also tried from 4.7 to 4.8 first.

There was no ssh connection or file opened when I tried.

Thanks for any help.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5246
Joined: Mon Oct 01, 2007 10:51 pm

Re: Can't update to 4.9 from 4.7

Post by admin » Mon May 28, 2012 6:22 pm

What kind of error happens, when you press "check for update" on Meteohub's maintenance page?

ipe
Junior Boarder
Junior Boarder
Posts: 23
Joined: Sun Jul 31, 2011 10:00 am

Re: Can't update to 4.9 from 4.7

Post by ipe » Mon May 28, 2012 8:30 pm

It shows the right sequence

-> Checking for update
-> Download update
-> Ready to install 4.9i

But when I press install, the website disconnects after a few seconds, and when I reconnect, it still contains the 4.7 version.

Thanks!

ipe
Junior Boarder
Junior Boarder
Posts: 23
Joined: Sun Jul 31, 2011 10:00 am

Re: Can't update to 4.9 from 4.7

Post by ipe » Tue May 29, 2012 4:34 pm

At my own risk, I executed the script update.nslu2 (after backing up everything and stopping data log) and everything ok.

4.9 installed.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5246
Joined: Mon Oct 01, 2007 10:51 pm

Re: Can't update to 4.9 from 4.7

Post by admin » Tue May 29, 2012 5:13 pm

Sounds like some kind of USB stick related problem with NSLU2. Please keep an eye on "meteohub log" for error reports alarming on invalid data etc.

Post Reply