Alix.1D with Atheros Wireless G23DBM

and other offical x86 platforms like e-boxes and fitPC

Moderator: Mattk

Post Reply
Periklast
Junior Boarder
Junior Boarder
Posts: 34
Joined: Sun Apr 26, 2009 9:14 am

Alix.1D with Atheros Wireless G23DBM

Post by Periklast » Sun Apr 26, 2009 9:25 am

Hi,

I have a network mini-pci adaptor installed on my Alix. 1D. It's an Atheros Wireless G23DBM (model WLM54GP23).

I succesfully installed meteohub on a 4Gb cf card. I connected it by a internet-cable and could connect to the web-interface.
But there I want to connect to my wifi. I set the ssid, wep-key an click save. In the network-page, I see a extra ip-adress for wlan but when I disconnect the internet-cable I couldn't connect the webinterface by wlan.

Is this pci-adaptor compatible or am I doing something wrong?

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5921
Joined: Mon Oct 01, 2007 10:51 pm

Re:Alix.1D with Atheros Wireless G23DBM

Post by admin » Sun Apr 26, 2009 7:41 pm

Meteohub supports WLM54G23 (http://www.pcengines.ch/wlm54g23.htm) that has a AR5005 chip set in it. WLAN boards with Atheros AR5006X are not supported.

Which you have you can see from it's PCI-ID, must be 168c:001a (not 168c:001b).

Periklast
Junior Boarder
Junior Boarder
Posts: 34
Joined: Sun Apr 26, 2009 9:14 am

Re:Alix.1D with Atheros Wireless G23DBM

Post by Periklast » Tue Aug 18, 2009 9:15 am

Are there plans to work with this chip set? If yes, I should buy meteohub I think, else it's useless for me..

hfischer
Fresh Boarder
Fresh Boarder
Posts: 5
Joined: Wed Dec 05, 2018 12:07 am

Re: Alix.1D with Atheros Wireless G23DBM

Post by hfischer » Sat Dec 22, 2018 7:21 pm

Hello,

ten years later, I seem to have an identical problem:

I am trying to add WLAN to my ALIX.2D3 using a WLM54G card (difficult to find nowadays!). The label on the card says just "WLM54G", without the "23" - this lokks as if if were the wrong card. But on the other hand, the PCI-ID is the correct one mentioned below by admin (168c:0001a).

I have the same symptoms as described by Periklast. I even can see the additional WiFi IP number and can use it to logon to Meteohub, but as soon as I pull the ethernet cable, the connection breaks down, for the WiFi and for the ethernet address. When I boot Meteohub without cable connection, it is not accessible.

It seems that the card is recognized by the system, there are several lines in dmesg with "wlan0".

I have tried several configuration and reboot sequences without success:
- configure and activate WLAN - shutdown - disconnect power - pull ethernet cable - connect power
- configure and activate WLAN - restart - pull ethernet cable during shutdown - wait for reboot
- configure and activate WLAN - restart - wait for reboot - pull ethernet cable

Any new insights, hints or ideas for workarounds?

Season's Greetings to everyone!

Yours, Helmut

hfischer
Fresh Boarder
Fresh Boarder
Posts: 5
Joined: Wed Dec 05, 2018 12:07 am

Re: Alix.1D with Atheros Wireless G23DBM

Post by hfischer » Sun Dec 23, 2018 8:26 pm

What shall I say - it works :-)

Maybe it was just a matter of patience - after removing power the Alix board forgets its date and time settings, and according to the log then realizes that the weather station has different settings. It appears to take a while until all is set. And it takes some minutes until the system shows up in my WiFi network.

Yours, Helmut

Post Reply