"Invalid peer certificate" Error v5.0g iConnect **solved**

discussion related to Iomega iConnect and Silverstone DC01 as Meteohub Platform

Moderator: Mattk

Post Reply
User avatar
AlaskaWX
Fresh Boarder
Fresh Boarder
Posts: 19
Joined: Thu Apr 05, 2012 7:46 pm

"Invalid peer certificate" Error v5.0g iConnect **solved**

Post by AlaskaWX » Fri Mar 13, 2015 2:38 am

Just tried the 5.0g meteohub update on iConnect platform and am getting an

Code: Select all

Mail send failed: Invalid peer certificate (error 20)#0 (null)#xxx@yyyy.com: 0 (null)
error when setting up and testing TLS push service to gmail.com. Any fixes planned for this condition?

FYI: meteohub version 4.9y was the last version that didn't have this problem! :?

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5423
Joined: Mon Oct 01, 2007 10:51 pm

Re: "Invalid peer certificate" Error on version 5.0g in iCon

Post by admin » Fri Mar 13, 2015 8:28 pm

Could you please give me remote access to your system on port 22 and 7777?

I moved from esmtp to msmtp on the x86 and RPI platforms to solve this issue.
Although the iConnect is no longer a fully supported platform, I would like to fix this
also for iConnect. At least I would like to try.

User avatar
AlaskaWX
Fresh Boarder
Fresh Boarder
Posts: 19
Joined: Thu Apr 05, 2012 7:46 pm

Re: "Invalid peer certificate" Error on version 5.0g in iCon

Post by AlaskaWX » Sat Mar 14, 2015 12:15 am

Boris,

I can start-up the reverse SSH tunnel to give you access to a second "test" system I have running in demo mode that you can play with for troubleshooting purposes.

User avatar
AlaskaWX
Fresh Boarder
Fresh Boarder
Posts: 19
Joined: Thu Apr 05, 2012 7:46 pm

Re: "Invalid peer certificate" Error on version 5.0g in iCon

Post by AlaskaWX » Mon Mar 23, 2015 1:52 am

Thanks Boris. The 5.0i update solved the problem and is working great now!

Post Reply