Can't get mhminix-v4.9q-v3.img to work with Mini X Plus 1GB

Allwinner A10 systems

Moderator: Mattk

nordstrandqueen
Junior Boarder
Junior Boarder
Posts: 29
Joined: Sun Dec 16, 2012 9:22 pm
Location: Lake Neusiedl, Austria

Re: Can't get mhminix-v4.9q-v3.img to work with Mini X Plus

Post by nordstrandqueen » Tue Jul 02, 2013 11:08 am

Hi,

I had success yesterday installing a new firmware on my MK805/MiniXplus.

I've used the H24 firmware (20130202) image from here:
http://www.minixplus.com/downlist/list-112-1.html
With the Windows tool PhoenixCard that can also be found there I copied this image onto my MircroSD card and could install it on my MK805/MiniXplus device.

I've written a detailed description for it here:
http://tabletrepublic.com/forum/android ... #post43762

Now the device works really quick with Android compared to the original software and it shows a MiniX logo first when booting.

After that firmware upgrade I copied the meteohub image onto the card again with dd bs=1M.
But meteohub still does not show up on the TV screen. Only differnce to before: After booting I see a white flickering stripe on the bottom of the screen. Besides that it stays black. But it's one more sign that the device seems to boot, but can't send the right output to the TV.

I've also tried to connect the TV with the AV cables, but that doesn't work at all.

Now I had another idea:
If the MK805/MiniXplus is booting, in fact I don't need TV output. That would be for configuration only. Afterwards the device should run as a server for my weather station without screen, mouse and keyboard.

So if I can configure the meteohub system for my WiFi network by making settings in the linux files on the card over my PC, it would work too and I could make all other weather station config in the web interface later.
It that true or is there any error in my reasoning?

Stef

Update 1:
Doesn't look good... I've tried to give the MiniX wifi access now, but without any success. Maybe it's not booting completely.
I tried to change the wifi settings of my router, but the passphrase "meteohub" obviously is not valid for WPA2. Then I tried to change wifi settings on the MicroSD card with meteohub in /etc/network/interfaces - but it never shows up in my network :cry:
Any ideas would be appreciated!!!

Update 2:
Very strange: I found out, that if I make changes in /etc/network/interfaces and try the MicroSD card again with the Mini-X, afterwards the /etc directory is not there any more.
weather station newbie, but IT & web pro
TE831X + SheevaPlug + meteohub

Jbrown261
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Thu Oct 31, 2013 5:41 am

Re: Can't get mhminix-v4.9q-v3.img to work with Mini X Plus

Post by Jbrown261 » Thu Oct 31, 2013 5:46 am

Has any one got the mini x plus to boot from this img ?

nordstrandqueen
Junior Boarder
Junior Boarder
Posts: 29
Joined: Sun Dec 16, 2012 9:22 pm
Location: Lake Neusiedl, Austria

Re: Can't get mhminix-v4.9q-v3.img to work with Mini X Plus

Post by nordstrandqueen » Mon Oct 14, 2019 11:00 am

Jbrown261 wrote:
Thu Oct 31, 2013 5:46 am
Has any one got the mini x plus to boot from this img ?
It never worked for me... I ended up buying a SheevaPlug back then. Now I would probably go for Raspberry Pi - the newer ones have built-in WiFi already.
weather station newbie, but IT & web pro
TE831X + SheevaPlug + meteohub

Post Reply