Meteobridge NANO SD - a NANO with local storage

All about the standard Meteobridge devices based on mobile routers from TP-Link, D-Link, ASUS

Moderator: Mattk

Phily
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Fri May 31, 2019 1:07 am

Re: Meteobridge NANO SD - a NANO with local storage

Post by Phily »

I've just got a Nano SD today and I've followed the instructions - so its now on my network, pingable etc.
When I browse to the address, it asks for he username/password and then hangs at http://<device IP>/cgi-bin/meteobridge and doesn't load - looks like the browser is waiting on the webserver but nothing happens.

Any suggestions?

Update - looks like the device (Nano, not the Davis unit) keeps on rebooting - the main chip on the board is getting incredibly hot, maybe its over heating?

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 6140
Joined: Mon Oct 01, 2007 10:51 pm

Re: Meteobridge NANO SD - a NANO with local storage

Post by admin »

Sounds like a hardware problem to my. Initial setup went fine?

Phily
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Fri May 31, 2019 1:07 am

Re: Meteobridge NANO SD - a NANO with local storage

Post by Phily »

All since resolved, turned out I didn't 'test' the WiFi settings during the initial setup but even when that was slipped it was connecting to my local network so unsure why that was required or different.
Now to look to mod the battery case to allow ventilation around the Nano while having the better case on

rzelle-K1TTC
Gold Boarder
Gold Boarder
Posts: 166
Joined: Fri Jul 12, 2019 4:32 pm
Contact:

Re: Meteobridge NANO SD - a NANO with local storage

Post by rzelle-K1TTC »

I am seeing this error in my Sun Position box on the Console Display page:
Fatal error: Uncaught Exception: DateTimeZone::__construct(): Unknown or bad timezone (America/New York) in /tmp/mnt/PWS/MB/sun.php:5 Stack trace: #0 /tmp/mnt/PWS/MB/sun.php(5): DateTimeZone->__construct('America/New Yor...') #1 /tmp/mnt/PWS/MB/sun.php(5): sunPos-

My System:
Platform: Meteobridge NANO SD (ambientweather Version)
RAM: 125572 kB total, 62296 kB free (50% used)
Storage: swissbit SLC, 1826 MB total, 1786 MB free (2% used)
SW Version: Meteobridge 4.0 (Jul 7 2019, build 2166), FW 1.3
Uptime: 3 days, 5 hours, 54 minutes Buffer: 1000 items (100%)

Located in Methuen, MA US so America/New York is the required local time zone.

Is this a Bug or can it be resolved with a settings change?

User avatar
weatherist34
Platinum Boarder
Platinum Boarder
Posts: 559
Joined: Tue Mar 28, 2017 6:57 am

Re: Meteobridge NANO SD - a NANO with local storage

Post by weatherist34 »

rzelle-K1TTC wrote:
Sun Jul 14, 2019 3:20 am
I am seeing this error in my Sun Position box on the Console Display page:
Fatal error: Uncaught Exception: DateTimeZone::__construct(): Unknown or bad timezone (America/New York) in /tmp/mnt/PWS/MB/sun.php:5 Stack trace: #0 /tmp/mnt/PWS/MB/sun.php(5): DateTimeZone->__construct('America/New Yor...') #1 /tmp/mnt/PWS/MB/sun.php(5): sunPos-

My System:
Platform: Meteobridge NANO SD (ambientweather Version)
RAM: 125572 kB total, 62296 kB free (50% used)
Storage: swissbit SLC, 1826 MB total, 1786 MB free (2% used)
SW Version: Meteobridge 4.0 (Jul 7 2019, build 2166), FW 1.3
Uptime: 3 days, 5 hours, 54 minutes Buffer: 1000 items (100%)

Located in Methuen, MA US so America/New York is the required local time zone.

Is this a Bug or can it be resolved with a settings change?

new york timezone php America/New_York note the lower dash between new york

https://www.php.net/manual/en/timezones.america.php

rzelle-K1TTC
Gold Boarder
Gold Boarder
Posts: 166
Joined: Fri Jul 12, 2019 4:32 pm
Contact:

Re: Meteobridge NANO SD - a NANO with local storage

Post by rzelle-K1TTC »

Thanks That fixed it I was able to add the _ in the Console Settings. Under the System Tab however the _ do not show.

Thanks Again Great Job on the Console ..:-)

rzelle-K1TTC
Gold Boarder
Gold Boarder
Posts: 166
Joined: Fri Jul 12, 2019 4:32 pm
Contact:

Re: Meteobridge NANO SD - a NANO with local storage

Post by rzelle-K1TTC »

Since I enabled Home Weather Station under Weather Nets and using http://mylocal ip/PWS/login.php as the API URL which give me green check my Live Data for the HWS is throwing a red X error see :
e&quot; content=&quot;yes&quot;&gt; &lt;meta name=apple-mobile-web-app-title content=&quot;HOME WEATHER STATION&quot;&gt; &lt;meta name=&quot;viewport&quot; content=&quot;width=device-width, height=device-height, initial-scale=1, viewport-fit=cover&quot;&gt; &lt;link rel=&quot;apple-touch-icon&quot; sizes=&quot;180x180&quot; href=&quot;img/apple-touch-icon.png&quot;&gt; &lt;link rel=&quot;icon&quot; type=&quot;image/png&quot; href=&quot;img/favicon-32x32.png&quot; sizes=&quot;32x32&quot;&gt; &lt;link rel=&quot;icon&quot; type=&quot;image/png&quot; href=&quot;img/favicon-16x16.png&quot; sizes=&quot;16x16&quot;&gt; &lt;link rel=&quot;manifest&quot; href=&quot;img/manifest.json&quot;&gt; &lt;meta name=&quot;theme-color&quot; content=&quot;#ffffff&quot;&gt; &lt;link href=&quot;favicon.ico&quot; rel=&quot;shortcut icon&quot; type=&quot;image/x-icon&quot;&gt; &lt;link href=&quot;favicon.ico&quot; rel=&quot;icon (4 more tries, next in 5 secs)<BR>')">

What am I doing wrong ..?

augiedoggie49
Fresh Boarder
Fresh Boarder
Posts: 5
Joined: Fri Nov 15, 2019 6:15 am

Re: Meteobridge NANO SD - a NANO with local storage

Post by augiedoggie49 »

I have the uncaught error for the sun position too, but I don't know how to edit the console settings. My timezone is Los Angeles. I think the '_' is causing the problem. I tried changing the timezone to one that is one word and rebooted, but the weather43 page still sees the old Los Angeles timezone with the missing symbol. Can anyone help?

xray77
Senior Boarder
Senior Boarder
Posts: 42
Joined: Sat Mar 07, 2020 11:54 pm
Location: Buedelsdorf, SH Germany
Contact:

Re: Meteobridge NANO SD - a NANO with local storage

Post by xray77 »

ConligWX wrote:
Sun Dec 09, 2018 2:08 pm
ssh to meteobridge

vi /www/PWS/cam.php

or if your main PC is windows based, then use Winscp and notepad++

simple.
Hello, I'm a newbie with a MBNano SD (AWEKAS-Version),
I have tried this tip, but my MBNano SD want to have a password to login with ssh.. The initial password "meteobridge" don't works.. What can I do to get access to the normally hidden directory /www/PWS/ to edit the webcamsmall.php for my webCam-URL? I work on a Mac, no Windows-PC. Thanks for any tipps
best regards
Mike
priv. Weatherstation Buedelsdorf SH Germany
https://buedelsdorfwetter.de/template

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 6140
Joined: Mon Oct 01, 2007 10:51 pm

Re: Meteobridge NANO SD - a NANO with local storage

Post by admin »

ssh login password is kept in sync with the HTTP login password. So please try your web admin password. User is root.

xray77
Senior Boarder
Senior Boarder
Posts: 42
Joined: Sat Mar 07, 2020 11:54 pm
Location: Buedelsdorf, SH Germany
Contact:

Re: Meteobridge NANO SD - a NANO with local storage

Post by xray77 »

Hello,
so yet i had'nt set a http-password, I have do it now. Unfortunately, i can't login on ssh-console, on there it would not ask of an username, only password.. I tried it with my new http-password and receive only an access denied..
Is the reason now because I could not enter a username?
I would be happy with more tips... :-)

Edit: I have found the issue: syntax for the ssh-call must be root@IP of Meteobridge and after return follow the PW-request.. All works now as it expect :) :)
Thanks for your help
regards
mike
priv. Weatherstation Buedelsdorf SH Germany
https://buedelsdorfwetter.de/template

Post Reply