Page 1 of 2

Nano SD Trouble enabling HWS dashboard

Posted: Sat May 11, 2019 7:33 pm
by mthiessen
Last week I installed MB Nano SD and all is smooth so far. Now I'm trying to enable the Home Weather Station dashboard. I can't find precise instructions how to do this.
Here is what I did:
Added Local Dashboard in the Weather Nets tab.
Registed at DarkSky and CheckWX, received keys and added them.
Clicked Save at the bottom of page.

When I click "remote Display" I think I should be seeing the HWS dashboard but instead I get Not Found. The URL the "remote Display" button is attempting is "https://admin.meteobridge.com/MBuniqe/PWS/index.php" where "MBunique" is the unique code to access my MB via web.

I'm located across the country from my Vantage Pro2 so I hope I don't need to tweek any of the template files on the MB drive share. I just returned last night.

Re: Nano SD Trouble enabling HWS dashboard

Posted: Sat May 11, 2019 11:28 pm
by Mattk
URL appears ok, do you have the Internet remote Login ticked on the System tab?

Re: Nano SD Trouble enabling HWS dashboard

Posted: Sun May 12, 2019 1:17 am
by mthiessen
Yes I have checked "Allow login from the Internet via this URL". This is the only way I use it since it's a across the country.
On a side note, I clicked "Reboot" button to install the May 11 update and it appeared to go offline for a minute or so but when it came back up it still slowed the May 5 version as in "May 5 2019, build 2081"

I have Version Control set to "get newest on boot". Before I installed the Nano a week ago, I used Meteobridge on a TP-Link to great success.

Do I need to sign in as root or something?

Re: Nano SD Trouble enabling HWS dashboard

Posted: Sun May 12, 2019 2:21 am
by Mattk
Saw this reboot/FW update issue a few days ago in conjunction with another issue. Only way I found to pick up the latest FW was to recycle the power

viewtopic.php?p=29139#p29139

Re: Nano SD Trouble enabling HWS dashboard

Posted: Sun May 12, 2019 3:07 am
by mthiessen
I was clever enough to plug the Davis console into a WiFi switch. But I noticed upon cycling power I need to hold long press the Done button on console to get it to exit setup mode. Not sure if it will do it itself.

Re: Nano SD Trouble enabling HWS dashboard

Posted: Sun May 12, 2019 6:18 pm
by admin
NANO does quit console setup mode in restart.

Re: Nano SD Trouble enabling HWS dashboard

Posted: Sun May 12, 2019 6:41 pm
by mthiessen
I just cycled power on the consol remotely and it exited setup mode after 10 minutes. It turns out older firmware won’t exit setup mode at all. Looks like I have newer firmware. When I get home I’ll check the url to see if I can get to MB nano.

Re: Nano SD Trouble enabling HWS dashboard

Posted: Sun May 12, 2019 8:56 pm
by mthiessen
MB Nano rebooted successfully and installed the latest update.

Now back to my original problem. How to get HWS dashboard working. Remote Display button results with a web page error "Not Found".
The URL is https://admin.meteobridge.com/b2.....4f/PWS/index.php

Weather Network status on the Live Data tab reports
Dashboard Update: 2019-05-12 11:39:04 Error: 2019-05-12 11:39:03 (no more tries)

Are there any instructions online about how to get HWS working on MB Nano SD?

Thanks,
Mark

Re: Nano SD Trouble enabling HWS dashboard

Posted: Sun May 12, 2019 9:15 pm
by ConligWX
Only a suggestion,

firstly recheck your Dark Sky and CheckWX api keys are correct.

does the "local Display" work? http://<ip-of-nano>/PWS/index.php

if yes, goto the Settings of PWS and setup the PWS. http://<ip-of-nano>/PWS/easyweathersetup.php

once setup, see if the remote Display then works

Re: Nano SD Trouble enabling HWS dashboard

Posted: Sun May 12, 2019 9:33 pm
by mthiessen
I rechecked the DarkSky and CheckWX keys and they are correct.

The "local Display" button opens a browser page with this URL: https://admin.meteobridge.com/b2...4f/PWS/index.php
The "remote Display" button opens the same browser page URL. https://admin.meteobridge.com/b2...4f/PWS/index.php

I changed the browser URL to http://external-ip-of-nano/PWS/index.php but received "Safari can't connect to server"
I'm assuming your "<ip-of-nano>" is my external IP of the MB network. This weather station is across the country and I will be there again in 5 weeks.

Do I need to setup HWS locally? When I was there last week on the same network I could get to MB via: http://10.0.1.15/cgi-bin/meteobridge and via the Internet URL.

Re: Nano SD Trouble enabling HWS dashboard

Posted: Mon Jun 17, 2019 4:01 pm
by mthiessen
I still can't get HWS (weather34) to work on my NanoSD.

I'm now across the country at my weather station so I can work on the local network where the Nano is located. I'm here for a week so I'd really like to get this working while I'm here.

The "local Display" button results in "Not Found" when it open a browser page with this URL: https://admin.meteobridge.com/b2...4f/PWS/index.php
I'm assuming it should be the internal IP http://10.0.1.15/PWS/index.php (I view Nano using both internal and eternal IP's)

The "remote Display" button results in "Not Found" when it open a browser page with this URL. https://admin.meteobridge.com/b2...4f/PWS/index.php

I changed the browser URL to http://external-ip-of-nano/PWS/index.php but received "Safari can't connect to server"

I rechecked the DarkSky and CheckWX keys and they are correct.

Platform: Meteobridge NANO SD (ambientweather Version)
RAM: 125572 kB total, 51016 kB free (59% used)
Storage: swissbit SLC, 1825 MB total, 1782 MB free (2% used)
SW Version: Meteobridge 4.0 (Jun 15 2019, build 2160), FW 1.3
Uptime: 1 days, 15 hours, 39 minutes Buffer: 1000 items (100%)

Re: Nano SD Trouble enabling HWS dashboard

Posted: Mon Jun 17, 2019 10:07 pm
by Mattk
So does PWS work locally? your.local.mb.ip//PWS/index.php

Do you have Internet Remote Login: ticked on the system page?

Have you tried a different browser? IE or Chrome

Re: Nano SD Trouble enabling HWS dashboard

Posted: Mon Jun 17, 2019 10:23 pm
by mthiessen
No it doesn't work locally.

I have remote login ticked which is how I mostly access Meteobridge when I'm not here.

I tried with Chrome and got the same result.

I am able to have MB send out to various web sites.

Re: Nano SD Trouble enabling HWS dashboard

Posted: Mon Jun 17, 2019 10:59 pm
by Mattk
Might be a silly question but Local Dashboard is showing in the Weather Nets tab and it has been saved?

Re: Nano SD Trouble enabling HWS dashboard

Posted: Mon Jun 17, 2019 11:31 pm
by mthiessen
Yes it’s in weather nets tab and I have the two api keys and they are correct.