Page 2 of 2

Re: MB reporting way too much rain

Posted: Thu Jul 25, 2019 2:22 pm
by doncurtis
Got a little rain last night

First screeshot what MB shows in live data and sent to WU.. 0.26" of rain (WU rounds to 0.30")

2nd image, what WLL reports to query.. 1 tick or 0.01" of rain

Re: MB reporting way too much rain

Posted: Fri Aug 02, 2019 11:17 pm
by doncurtis
Another recent rainstorm. Console and weatherlink.com show the correct amount of 0.07 inches
MB reported 1.78 inches to the 3 networks it reports to.

Approx 24 times too much rain.

Re: MB reporting way too much rain

Posted: Sat Aug 03, 2019 12:59 am
by galfert
I think it would be good to determine if this is a WLL issue or a Meteobridge issue. One thing to look into is to see if there are WLL users having this issue with other software like Weather-Display (that reads WLL too right?).

Re: MB reporting way too much rain

Posted: Sat Aug 03, 2019 1:14 am
by Mattk
doncurtis wrote:
Fri Aug 02, 2019 11:17 pm
Another recent rainstorm. Console and weatherlink.com show the correct amount of 0.07 inches
MB reported 1.78 inches to the 3 networks it reports to.

Approx 24 times too much rain.
That difference is purely the difference between inches and mm (as opposed to inches and inches) 0.07 inches is 1.778mm, rounded is 1.78mm but being interpreted for some reason as inches

Re: MB reporting way too much rain

Posted: Sat Aug 03, 2019 1:31 am
by doncurtis
gus wrote:
Sat Aug 03, 2019 12:59 am
I think it would be good to determine if this is a WLL issue or a Meteobridge issue. One thing to look into is to see if there are WLL users having this issue with other software like Weather-Display (that reads WLL too right?).
No idea on weather display, but the WLL sends data to (or gets a query from) weatherlink.com and the data there is correct. Weatherlink.com then sends the data to WU (I created a duplicate WU site to my real site) and that duplicate site reads identical EXCEPT rain amounts to my real site that is fed by MB (reading from the WLL).

In addition, one or two messages back, I posted http query results from the WLL alongside MB live data. The live data shows about 25 times more rain than the http query.

The http query values are correct and agree with the NOAA station that is a couple of miles away.

I can only conclude the MB is somehow interpreting improperly what it is getting from MB's query of the WLL.

BTW, when there is no rain, both MB and weatherlink.com properly report zero.

Re: MB reporting way too much rain

Posted: Sat Aug 03, 2019 1:38 am
by doncurtis
Mattk wrote:
Sat Aug 03, 2019 1:14 am
doncurtis wrote:
Fri Aug 02, 2019 11:17 pm
Another recent rainstorm. Console and weatherlink.com show the correct amount of 0.07 inches
MB reported 1.78 inches to the 3 networks it reports to.

Approx 24 times too much rain.
That difference is purely the difference between inches and mm (as opposed to inches and inches) 0.07 inches is 1.778mm, rounded is 1.78mm but being interpreted for some reason as inches
The station is setup in MB as a 0.01" per tick, the http query shows "rain_size" as 1 (if a tick was 0.2mm, rain_size is returned as 2)

The shot of live data from MB a few messages back shows MB showing 6.5mm/0.26 inches from 1 tick

Re: MB reporting way too much rain

Posted: Thu Aug 08, 2019 11:53 pm
by admin
Please try just released version which should have this fixed.

Re: MB reporting way too much rain **solved**

Posted: Sun Aug 11, 2019 4:10 pm
by doncurtis
It is fixed, got a little bit of rain last night and it's now reported correctly.

Thank you Boris!