After update to 4.1 no FTP upload and historical data missing. **solved**

All about the standard Meteobridge devices based on mobile routers from TP-Link, D-Link, ASUS

Moderator: Mattk

User avatar
wsnoordbergum
Expert Boarder
Expert Boarder
Posts: 91
Joined: Wed Jan 14, 2015 12:33 pm
Location: Friesland/Netherlands
Contact:

Re: After update to 4.1 no FTP upload and historical data missing.

Post by wsnoordbergum » Mon Sep 02, 2019 1:04 pm

Seems like the history file is corrupted so MB can't load twhe data.
Or in worst case scenario, the file is deleted from the server.

I hope the problem can be fixed.

Wsnoordbergum

heersje
Fresh Boarder
Fresh Boarder
Posts: 12
Joined: Fri May 05, 2017 12:39 pm

Re: After update to 4.1 no FTP upload and historical data missing.

Post by heersje » Tue Sep 03, 2019 8:38 am

It looks like Meteobridge 4.1 (Aug 31 2019, build 13123) is working now without FTP issues or historic data loss on my TL-MR3020. So what remains is manually reentering historic data

wje
Fresh Boarder
Fresh Boarder
Posts: 8
Joined: Wed Jun 22, 2016 4:31 pm

Re: After update to 4.1 no FTP upload and historical data missing.

Post by wje » Wed Sep 04, 2019 7:49 pm

Are there any updates on a 4.1 fix for MR3040?? 4.0 works, 4.1 does not.

In 4.1 I am unable to "Reload template" and receive error: Error (Event #02): Download of template failed: /bin/sh: /home/openssl/wget-ssl: not found.
This error does not occur in 4.0.

In 4.1 my FTP test is failing with: Error: FTP test upload failed: sh: ncftpput: not found
It works fine in 4.0.

Also, my history is gone.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5879
Joined: Mon Oct 01, 2007 10:51 pm

Re: After update to 4.1 no FTP upload and historical data missing.

Post by admin » Wed Sep 04, 2019 11:02 pm

Just applied the fix to MR3040 platform. Please reboot.

ve7gel
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Thu Aug 29, 2019 3:22 pm
Location: Vancouver Island, BC, CA

Re: After update to 4.1 no FTP upload and historical data missing.

Post by ve7gel » Thu Sep 05, 2019 12:08 am

heersje wrote:
Tue Sep 03, 2019 8:38 am
It looks like Meteobridge 4.1 (Aug 31 2019, build 13123) is working now without FTP issues or historic data loss on my TL-MR3020. So what remains is manually reentering historic data
Same situation here. FTP is now working with this build, just missing historical data.

wje
Fresh Boarder
Fresh Boarder
Posts: 8
Joined: Wed Jun 22, 2016 4:31 pm

Re: After update to 4.1 no FTP upload and historical data missing.

Post by wje » Thu Sep 05, 2019 12:11 am

I applied the Sept 5 update (Meteobridge 4.1 (Sep 4 2019, build 13124), FW 1.4 ).

Still not working.
When I press "Reload Template" I receive:
System Message
Error (Event #02): Download of template failed: /home/openssl/wget-ssl: can't load library 'libc.so'

wje
Fresh Boarder
Fresh Boarder
Posts: 8
Joined: Wed Jun 22, 2016 4:31 pm

Re: After update to 4.1 no FTP upload and historical data missing.

Post by wje » Sat Sep 07, 2019 3:30 pm

I've updated to the newest release of 4.1 (September 7, 2019) and now my 3040 is stuck in a never-ending reboot cycle.

How can I recover from this? Anything above 4.0 on the 3040 is outright not working for me.

User avatar
wsnoordbergum
Expert Boarder
Expert Boarder
Posts: 91
Joined: Wed Jan 14, 2015 12:33 pm
Location: Friesland/Netherlands
Contact:

Re: After update to 4.1 no FTP upload and historical data missing.

Post by wsnoordbergum » Mon Sep 09, 2019 12:15 pm

Has anyone tried the latest version on a TP-Link TL WR703N yet?
I'm still running the 3.9 version, which is running smoothly.
I'm afraid I loose my data again when updating to 4.1

Only if 4.1 is absolutely fine and bug free, I will ty it.

wsNoordbergum

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5879
Joined: Mon Oct 01, 2007 10:51 pm

Re: After update to 4.1 no FTP upload and historical data missing.

Post by admin » Tue Sep 10, 2019 8:55 am

Remaining problem seems to just impact the less commonly used MR3040 only. Unfortunately, I could not reproduce the issue on my test equipment so far.

wje
Fresh Boarder
Fresh Boarder
Posts: 8
Joined: Wed Jun 22, 2016 4:31 pm

Re: After update to 4.1 no FTP upload and historical data missing.

Post by wje » Wed Sep 11, 2019 3:02 am

Does this mean the MR3040 is not supported anymore? It works fine with the 4.0 release, but nothing later.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5879
Joined: Mon Oct 01, 2007 10:51 pm

Re: After update to 4.1 no FTP upload and historical data missing.

Post by admin » Wed Sep 11, 2019 4:47 pm

it is supported and runs great here.
Screenshot 2019-09-11 at 16.46.13.png
Screenshot 2019-09-11 at 16.46.13.png (108.96 KiB) Viewed 154 times

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5879
Joined: Mon Oct 01, 2007 10:51 pm

Re: After update to 4.1 no FTP upload and historical data missing.

Post by admin » Wed Sep 11, 2019 5:06 pm

@wje: without a direct look at your system I will not be able to troubleshoot this as it works fine on my rig.

wje
Fresh Boarder
Fresh Boarder
Posts: 8
Joined: Wed Jun 22, 2016 4:31 pm

Re: After update to 4.1 no FTP upload and historical data missing.

Post by wje » Sat Sep 14, 2019 5:22 pm

@admin - I've sent you a message with my meteobridge info

Running the latest Meteobridge 4.1 (Sep 14 2019, build 13143), FW 1.4 on a 3040

When I try "Reload Template" I still receive:
Error (Event #02): Download of template failed: /home/openssl/wget-ssl: can't load library 'libc.so'
I think this is why my ftp stopped working - it can't pull the template to form the file.

Other services like mySQL and PWS work fine.

My template is stored on a website which requires https. Again, it works on 4.0, but not any release since then.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5879
Joined: Mon Oct 01, 2007 10:51 pm

Re: After update to 4.1 no FTP upload and historical data missing.

Post by admin » Sat Sep 21, 2019 10:14 am

with just released update issue is fixed for TL-MR3040 platform. It was a missing install statement for this particular HW platform. Sorry, that it did take so long.

User avatar
gus
Senior Boarder
Senior Boarder
Posts: 68
Joined: Sun Jun 24, 2018 10:31 pm
Location: Orlando, FL

Re: After update to 4.1 no FTP upload and historical data missing. **solved**

Post by gus » Sat Sep 21, 2019 2:55 pm

What about the other issue....missing historical data. Is there a way to get it back?
MR3020 v1
GW1000

Post Reply