Weather34 TEMPLATE

All about the standard Meteobridge devices based on mobile routers from TP-Link, D-Link, ASUS

Moderator: Mattk

User avatar
weatherist34
Platinum Boarder
Platinum Boarder
Posts: 829
Joined: Tue Mar 28, 2017 6:57 am
Contact:

Re: Weather34 TEMPLATE

Post by weatherist34 »

hello if this the internal nanosd screen version you may want too raise the issue here viewtopic.php?f=61&t=15131

thats a very old dated version your displaying in the screenshot ..brian

BigAlT
Expert Boarder
Expert Boarder
Posts: 155
Joined: Tue Jul 04, 2017 8:41 pm
Location: Washington State

Re: Weather34 TEMPLATE

Post by BigAlT »

I did another reset of the Dashboard and it did update. The only two issues are the format of the upper left date module always shows in Day Month Year Format no matter which format I choose on the settings and in the Min Max upper window, the Max temp while actually showing the Max temp in degrees F as set in settings shows the C symbol in Orange.
EB8043A1-3B0B-464E-903C-83662934DFE8.jpeg
EB8043A1-3B0B-464E-903C-83662934DFE8.jpeg (479.53 KiB) Viewed 623 times

BigAlT
Expert Boarder
Expert Boarder
Posts: 155
Joined: Tue Jul 04, 2017 8:41 pm
Location: Washington State

Re: Weather34 TEMPLATE

Post by BigAlT »

I followed Boris’s instructions to load the most current version of the dashboard and it works fine. I do find that the Wunderground Forecast doesn’t load at all, I just get a blank screen when trying to show it. I’ve gotten and inserted a new Wunderground API key in the Nano SD Weather 34 Dashboard settings. Looking at my Wunderground API useage it shows a straight line of errors. Anyone have the same issue or is it related to the 2021 termination of the forecast API ?.
Even more confusing is that if I load the original dashboard version ( you can view both of them ) the forecast is displayed correctly.

atlantic21
Junior Boarder
Junior Boarder
Posts: 26
Joined: Sat Mar 07, 2020 8:58 pm

Re: Weather34 TEMPLATE

Post by atlantic21 »

Hello Brian, I am having the following problems with the 2 excel files each day I have to correct the duplicate dates on each file, also the year rain in the almanac has changed from when you last fixed
Thanks Richard

Rain .png
Rain .png (21.69 KiB) Viewed 579 times
Octob 2020.png
Octob 2020.png (3.75 KiB) Viewed 579 times
2020.png
2020.png (5.3 KiB) Viewed 579 times

User avatar
weatherist34
Platinum Boarder
Platinum Boarder
Posts: 829
Joined: Tue Mar 28, 2017 6:57 am
Contact:

Re: Weather34 TEMPLATE

Post by weatherist34 »

Hello look its not me or anything changing in template its in the firmware updates . I cant keep up and slowly watching it all fall apart :-( .

ill brake this down for you but in simple terms nothing changed in the template on how any almanac data is handled .

the two strings in the API have always been
[rain0total-max@M1] [rain0total-max@Y1]

because of the way sensors have started change the way they are handled for reasons beyond me or control they now appear in your API as below
this is why your are seeing the string output like that in the almanac because the template has no idea it exists..this just one of many Ive had reported this week ..

as per I guess a recent change in firmware update and your API output now outputs like this notice the !0 in the string..
[rain0!0total-max@M1] [rain0!0total-max@Y1]

I can vision template becoming completely messed up I can not follow the changes or have the enthusiasm todo so its a lot of work and your not the first to report this week anomalies with these new strings appearing for which I have no idea its all in the firmware so expect things to go terribly wrong randomly. I don't control the API output strings !!!

No idea why you are seeing duplicates is this a recent issue or long term because once again nothing changed in template apart from additional UV-Solar being added but that wouldn't cause duplicate lines .

So Im sticking to version 4.2 firmware ..

here is your API output which I do not change or have any control over you can clearly see its using [rain0!0total-max@M1] [rain0!0total-max@Y1]

03/10/2020 09:31:26 12.6 89.0 10.8 6.3 2.2 344.0 0.0 1.6 991.7 355.0 2 m/s C hPa mm 5.9 991.6 38.4 1114.6 29.8 18.9 68.0 12.1 12.7 12.7 20201003074342 11.6 20201003045243 7.6 20201003082958 14.3 20201003082756 993.8 20201003004257 991.3 20201003084458 4.4 13813 14.3 TL-MR3020 -- -- 20.6 -- 4.0 0.0 11.3 20201003080506 5.5 20201001225634 11.2 20201002234942 21.7 20200812193157 -4.1 20200321201319 -- 94.0 20201003000002 87.0 20201003013029 11.3 20201003080506 10.3 20201003013037 12.6 89.0 10.8 18.8 68 6.3 6.4 -- -- -- -- -- -- -- 394340 12.1 20201002234826 6.2 20201002000010 14.8 20201001134235 6.1 20201001231553 28.4 20200624145252 -0.3 20200326055726 16.1 20201002094012 16.1 20201002094012 30.0 20200209081904 29.8 38.4 20200129071315 1114.6 20200129071315 -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 5.8 20201002000010 0 12.6 20201003054058 28.4 20200624145252 -1.5 20200129071249 21.7 20200812193157 -4.1 20200321201319 30.0 20200209081904 993.7 20201002211800 983.4 20201002054258 1001.2 20201001000557 983.4 20201002054258 1041.0 20200329213408 982.3 20200229050705 1049.3 20200329213408 982.3 20200229050705 1114.6 12.2 4 98.1 11:28 19:47 08:41 6.2 100.0 20201002035716 67.0 20201001135506 100.0 20200302054801 30.0 20200529165801 100.0 20201002035716 87.0 20201002104208 0.0 0.0 [rain0!0total-max@M1] [rain0!0total-max@Y1] -- 12.6 991.8 -- 6.3 -- -- -- 89.4 12.4 3.7 20200129071249 20200129071233 138.6 7 4 152.7 29.8 20200625145130 -5.1 20200226001741 _Mostly cloudy and cooler. Precipitation possible within 12 hours, possibly heavy at times. Windy.

User avatar
weatherist34
Platinum Boarder
Platinum Boarder
Posts: 829
Joined: Tue Mar 28, 2017 6:57 am
Contact:

Re: Weather34 TEMPLATE

Post by weatherist34 »

BigAlT wrote:
Sat Oct 03, 2020 12:19 am
I followed Boris’s instructions to load the most current version of the dashboard and it works fine. I do find that the Wunderground Forecast doesn’t load at all, I just get a blank screen when trying to show it. I’ve gotten and inserted a new Wunderground API key in the Nano SD Weather 34 Dashboard settings. Looking at my Wunderground API useage it shows a straight line of errors. Anyone have the same issue or is it related to the 2021 termination of the forecast API ?.
Even more confusing is that if I load the original dashboard version ( you can view both of them ) the forecast is displayed correctly.
good morning can you discuss this in the internal nanosd thread it has more chance of being resolved as I dont have or control the internal versions of the NANOSD . this thread is about the web version. please dont misunderstand or take it the wrong way just I have no control over internal version..Brian

User avatar
weatherist34
Platinum Boarder
Platinum Boarder
Posts: 829
Joined: Tue Mar 28, 2017 6:57 am
Contact:

Re: Weather34 TEMPLATE

Post by weatherist34 »

@Atlantic21

I have just updated the simple update file download

I have put a fix in there but how many more will be required I have no idea . The TPLINK types don't have last months DATA for rainfall or Last Years

so I put these lines in there so it will just show N/A

if ($weather['rainlastmonth']=='[rain0total-max@M1]') {echo "N/A";}
if ($weather['rainlastmonth']=='[rain0!0total-max@M1]') {echo "N/A";}

if ($weather['rainlastyear']=='[rain0total-max@Y1]') {echo "N/A";}
if ($weather['rainlastyear']=='[rain0!0total-max@Y1]') {echo "N/A";}

Best I can do ...Brian

User avatar
prestwickwx
Gold Boarder
Gold Boarder
Posts: 313
Joined: Sat Aug 23, 2014 3:28 pm
Location: Myrtle Beach, SC USA
Contact:

Re: Weather34 TEMPLATE

Post by prestwickwx »

Hi Brian,

Looks like there is a small alignment issue on your latest uv-sun update. Seems to be with Chrome and Firefox on Windows and Chome on Mac - ok on IOS. Here is a screen shot:

Capture.PNG
Capture.PNG (21.87 KiB) Viewed 537 times

Take care,

Chuck
Last edited by prestwickwx on Sat Oct 03, 2020 4:35 pm, edited 1 time in total.
Image
https://myrtleweather.com/
Myrtle Beach WX @ Prestwick

User avatar
jasonmfarrow
Expert Boarder
Expert Boarder
Posts: 86
Joined: Mon May 25, 2020 4:21 pm
Contact:

Re: Weather34 TEMPLATE

Post by jasonmfarrow »

Brian, my cup overfloweth-ish.
Screenshot 2020-10-03 at 3 October 2020 13.39.51 pm.png
Screenshot 2020-10-03 at 3 October 2020 13.39.51 pm.png (62.91 KiB) Viewed 535 times
That's a lot of rain in less than 48-hrs and 82% of the monthly average rain in just three days.
Just wanted to show you a full cup. If only it would dribble over the edges...
Regards
Jason
jmfweather.uk | @jasonmfarrow

User avatar
weatherist34
Platinum Boarder
Platinum Boarder
Posts: 829
Joined: Tue Mar 28, 2017 6:57 am
Contact:

Re: Weather34 TEMPLATE

Post by weatherist34 »

FWIW everyone there is a lot of changes happening in meteobridge with mapping of sensors this introduces new strings unknowingly so therefore this may be the end of development , I simply can not adapt or have the inclination too simply as I have no means of knowing if users are using the mapping feature . what happens it changes what is in the API output and remember there are 196 API values so for me to try and fathom that lot out is like going back to square one and start again .

these are what I have had reported to me last two(24 hours) .
[th0!0temp-act:--]
[th0!0hum-act:--]
[th0!0dewact:--]

[rain0!0total-max@Y1]
[rain0!0total-max@M1]


from anyone looking at thinking this seems quite easy but its not because if the end user is using the mapping sensor feature then the normal API string is not produced but used but as above thus Ive no way of knowing and a possibility of 196 strings the could either contain !0 or the familiar just 0 as the primary id ...

think we need a young enthusiast with good design skills to come up with something because Im not feeling the enjoyment . Whilst Ill happily hold my hand up for mistakes I make without hesitation , this all seem to kick of with recent firmware updates and I get it has major benefit for end users wanting to mix and match low cost brands into a Davis environment etc or just use a multiple of brands but from a developer template side of things its a complete headache , lots of unknown scenarios just can appear unexpectedly without little chance of quick resolve..

@chuck Ill fix that normal firefox/chrome dont like the margin ..

User avatar
prestwickwx
Gold Boarder
Gold Boarder
Posts: 313
Joined: Sat Aug 23, 2014 3:28 pm
Location: Myrtle Beach, SC USA
Contact:

Re: Weather34 TEMPLATE

Post by prestwickwx »

Brian,

That fixed the alignment. :D

I am sticking with pre multiple sensor mapping firmware.

Many thanks,

Chuck
Image
https://myrtleweather.com/
Myrtle Beach WX @ Prestwick

User avatar
jasonmfarrow
Expert Boarder
Expert Boarder
Posts: 86
Joined: Mon May 25, 2020 4:21 pm
Contact:

Re: Weather34 TEMPLATE

Post by jasonmfarrow »

weatherist34 wrote:
Sat Oct 03, 2020 5:13 pm
these are what I have had reported to me last two(24 hours) .
[th0!0temp-act:--]
[th0!0hum-act:--]
[th0!0dewact:--]

[rain0!0total-max@Y1]
[rain0!0total-max@M1]
Brian, what setup do the users have that are reporting these values? Do you think they're trying to use the meteobridge mapping tools to map non-Davis sensor HW into the weather34 API and not quite working like the Davis?

I've got a Davis Vue, and the latest meteobridge firmware (and I'm using the default mappings except for the Airlink which needed to be mapped to use the sensors which output to API values 180,181, & 182) and I'm not seeing any of these bugs or missing values.

It may be a case that, as you've expressed elsewhere, you cannot be expected to support every version of every piece of hardware (especially hardware you do not own...)
Regards
Jason
jmfweather.uk | @jasonmfarrow

atlantic21
Junior Boarder
Junior Boarder
Posts: 26
Joined: Sat Mar 07, 2020 8:58 pm

Re: Weather34 TEMPLATE

Post by atlantic21 »

Brian thanks for the update now fixed

Richard

User avatar
weatherist34
Platinum Boarder
Platinum Boarder
Posts: 829
Joined: Tue Mar 28, 2017 6:57 am
Contact:

Re: Weather34 TEMPLATE

Post by weatherist34 »

jasonmfarrow wrote:
Sat Oct 03, 2020 6:23 pm
weatherist34 wrote:
Sat Oct 03, 2020 5:13 pm
these are what I have had reported to me last two(24 hours) .
[th0!0temp-act:--]
[th0!0hum-act:--]
[th0!0dewact:--]

[rain0!0total-max@Y1]
[rain0!0total-max@M1]
Brian, what setup do the users have that are reporting these values? Do you think they're trying to use the meteobridge mapping tools to map non-Davis sensor HW into the weather34 API and not quite working like the Davis?

I've got a Davis Vue, and the latest meteobridge firmware (and I'm using the default mappings except for the Airlink which needed to be mapped to use the sensors which output to API values 180,181, & 182) and I'm not seeing any of these bugs or missing values.

It may be a case that, as you've expressed elsewhere, you cannot be expected to support every version of every piece of hardware (especially hardware you do not own...)
who knows im NOT getting involved or attempting probably the point your not seeing the mapping is creating new strings in the api output that im not aware of ...i dont have any control over the API output it was developed in 2017 to use th0temp for example and 196 strings were added over that time now in last 24 hours suddenly th0!0temp is appearing the template as no idea what that is .. as richard highlighted suddenly he had
[rain0!0total-max@Y1]
appear which should have been [rain0total-max@Y1]
so as you can see the possibility of anything suddenly appearing with the string 0! unknowingly is going to create an headache and highly possible it will break template as the template expects th0temp etc . sorry to be negative but i saw this coming and feared it would begin to break things or cause unexpected display of strings as opposed to valus.

jason you have to look at the wider audience instead of your own back yard and needs to realize what works for one dont always work for the other..when you have multiple scenarios,configurations going on it gets extremely unreliable from this template ..sometimes technology moves on or evolves you either move with it or call it a day.. from my perspective there is no benefit or gain its really time some good designer/developer came along with a future proof approach..

xray77
Expert Boarder
Expert Boarder
Posts: 145
Joined: Sat Mar 07, 2020 11:54 pm
Location: Buedelsdorf, SH Germany
Contact:

Re: Weather34 TEMPLATE

Post by xray77 »

..I cannot do much with this new mapping feature of MeteoBridge, probably I am too old to understand how it works, maybe there will be a more detailed description in the future WIKI of MeteoBridge.
It would be a pity if the development of this very nice template would be stopped by you, Brian, because of these new incalculable scenarios. But I can understand the frustration about it and I hope that this template will be around for a long time and that you can continue to develop it, although it works pretty perfect as it is...
Best regards and many, many thanks for your work!
Mike

Post Reply