Local Dashboard updates stop on Nano SD

This section covers the Meteobridge PRO units exclusively

Moderator: Mattk

rks
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Mon Jun 03, 2019 9:28 pm

Local Dashboard updates stop on Nano SD

Post by rks »

Updates to the Local Dashboard stop randomly after a few hours or days following a reboot. The problem is indicated by the weather network status on the live data page which shows a green tick but the time of the last update does not change. The two external weather services in the Local Dashboard (Darksky and CheckWX) show the time of the last update and offline. Weather Underground updates also fail causing the buffer to fill to 100%. In both cases update requests are set to 1 minute and rebooting always starts normal updating but they eventually stop. I use a Davis Vantage VP 2 and a Nano SD, both 10 months old. This is a recent problem, in the past the system has run for over 100 days with no reboot. Now it’s every 2 or 3 days at most. I have reliable network links and all other Meteobridge functions I use continue to work well. Any suggestions as to the problem?

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 6247
Joined: Mon Oct 01, 2007 10:51 pm

Re: Local Dashboard updates stop on Nano SD

Post by admin »

Do you have additional batteries in the console? Which mA rating does the console power supply have?

rks
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks »

Apologies for delay in replying. I have new alkaline batteries fitted and the Davis psu is rated at 1 amp.

rks
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks »

Following a reply to an apparently similar problem in the Meteobridge discussion I swapped the Davis 1 amp supply for an uprated 2 amp supply. Unfortunately the problem reoccurred within 2 days with both the Local Dashboard and Weather Underground enabled. Rebooting cleared the problem. Note that the internet was running despite the WLAN IP indicating there was ‘no internet’. I suggest that this might be a clue to the update problem possibly the Nano SD is losing the internet connection for some reason.
System page at failure.
System page at failure.
1546018A-E5AC-4BBD-B6B5-B2D09B3A4F99.png (489.03 KiB) Viewed 1434 times

ToTo
Expert Boarder
Expert Boarder
Posts: 104
Joined: Wed Apr 03, 2019 9:24 am
Location: Magdeburg, Germany

Re: Local Dashboard updates stop on Nano SD

Post by ToTo »

I had similar problems with the Wlan connection. Set the wifi channel in the router fix and not automatically. Also change the used channel if there are further problems.

This helped me.

rks
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks »

Thanks ToTo, I’ll set up a fixed link, as you suggest. I already have the address reserved in the router. I appreciate your help.

rks
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks »

I have applied manual ip addresses, fixed channel 7 on the router as suggested by members and still the updates stopped, as can be seen from the attachments. The wifi signal is good and the WLAN is working. This had not used to happen when I first used Nano SD in May 2019. It is not possible to support Weather Underground or even local dashboard as it stands. Could the problem be the use of a wifi repeater, hence the two wistaria_2.4 signals?
Good signal and manual ip
Good signal and manual ip
1F818F2A-6AE5-4CC5-9A0D-5B4ADAA343B2.png (286.37 KiB) Viewed 1327 times
Attachments
No updates 3 hours, why has it stopped?
No updates 3 hours, why has it stopped?
A6C1FDCE-5743-452C-96C7-769A6A2B81AC.png (466.8 KiB) Viewed 1327 times
Buffer filling. WLAN connected
Buffer filling. WLAN connected
6D475A42-0451-49A8-BE49-129A4FE80AFA.png (463.33 KiB) Viewed 1327 times

ToTo
Expert Boarder
Expert Boarder
Posts: 104
Joined: Wed Apr 03, 2019 9:24 am
Location: Magdeburg, Germany

Re: Local Dashboard updates stop on Nano SD

Post by ToTo »

Too bad that the idea of finding a solution did not help. Can you see in your router, how strong is the Wlan connection to the NanaoSD? Maybe change the position and distance to the router?

rks
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks »

Agreed ToTo, but as I show in the network screen shot the Nano card ‘sees’ two router signals, one from the router directly (7%) and one from the repeater (99%). I assume the best signal is used but maybe it connects to the weaker signal on occasions causing problems. I’ve set to the router to avoid channel hopping at channel 7 as suggested elsewhere. My only other thought is to turn the repeater off and move the Davis Pro2 to a location with a better direct signal from the router and see if that cures the problem in the short term. However, the location would be unsatisfactory long term. Moving the router is not an option, after all that’s why we have repeaters.

rks
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks »

After removing the wifi extender from the room and repositioning the Vantage Pro2 console to obtain a good signal from the router the system has worked faultlessly for several days. I guess the problem is with the wifi extender which, despite providing a very good signal (see above attachment), does not work reliably with the Nano SD card. I have yet to try a replacement wifi extender to confirm whether the Nano SD will work reliably from a wifi extender or requires a direct signal from the router. Does anyone run their Nano SD card via a wifi extender?

garybridge
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Tue Nov 05, 2019 7:04 pm

Re: Local Dashboard updates stop on Nano SD

Post by garybridge »

Perhaps your WiFi repeater is not getting a good signal from the router? The meteo might be receiving a strong signal strength as RF power, but if the data is screwed it’s no use to you!

rks
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks »

Good point, thanks for your helpful reply. I have placed an old iPad in the same position on the wall as the Pro2 Console/Nano SD used to be be and with the wifi repeater on it worked with no problems, as indeed it does without the repeater despite only getting one bar on the signal strength indicator. The Console/Nano SD will not work at all reliably without the wifi extender but it maybe the extender needs a better signal than it receives, as you suggest. I think I’ll just keep my new setup as it is working well. I’ve just got to get used to having the console in a less convenient position.

thunderstorm
Junior Boarder
Junior Boarder
Posts: 38
Joined: Sun Mar 31, 2019 11:00 am

Re: Local Dashboard updates stop on Nano SD

Post by thunderstorm »

I'm also using a repeater (Fritz!Repeater 1750E) and seeing this issue as well. From time to time tmy nano-sd is no longer uploading data (though it's reachable in the webinterface). In rare cases it even stops logging data (buffer fills up), but I'm not sure whether the later is related to the connection.
My repeater has a good connection to the base AP (I'm doing video-conferences in this setup nowadays) and other devices connected to the repeater don't experience this problem. As in the setup of rks the nano is seeing both APs (~70%, ~20%), but I don't have the option to turn of the repeater.

rks
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks »

Thanks for you input, thunderstorm. I have run another device on the wifi extender in the same location and it worked faultlessly. I think we have highlighted a problem with the Nano SD when connected to a wifi repeater/extender and request please that this problem be identified and fixed. I would suggest that the presence of two SSIDs with the same name, which is the case with wifi extenders, may be the problem. There is no indication of how the Nano SD selects which SSID to connect to if more than one is found. I tried to manually select the SSID by placing a tick against the SSID with the best signal level (i.e. from the extender) shown in the drop down list of ‘Known SSIDs’ in the WiFi Client page and saving the result. However, the tick is lost when the page is displayed again so I guess the tick does nothing. I look forward to the resolution of this problem.

thunderstorm
Junior Boarder
Junior Boarder
Posts: 38
Joined: Sun Mar 31, 2019 11:00 am

Re: Local Dashboard updates stop on Nano SD

Post by thunderstorm »

Over the last 2 days it happened two times to me. Looks like most/all of the weatherdata related functionally stops working (export, writing to the DB), but the webui is still reachable with an acceptable latency & speed.
I can help myself with rebooting my repeater and then everything works fine again (and I don't loose any data).
That indicates to me that some processes are waiting for some signal or is some kind of blocked.

Is there a way to restart the WiFi interface on the nano ? From the openwrt interface it's not clear which one I should take - one has the IP but the other is showing the traffic
overview.png
overview.png (149.16 KiB) Viewed 1069 times
interfaces.png
interfaces.png (80.53 KiB) Viewed 1069 times
Thanks
Bernd

Post Reply