Bug with times in NOAA-style reports **solved**

This section covers the Meteobridge PRO units exclusively

Moderator: Mattk

Post Reply
chrysnic
Senior Boarder
Senior Boarder
Posts: 73
Joined: Fri Apr 25, 2014 11:41 am

Bug with times in NOAA-style reports **solved**

Post by chrysnic » Wed Nov 28, 2018 9:33 am

Hi all,

I have been using the NOAA-style templates on my MB Pro for the last few days, and I have noticed an issue with the times printed in the report. There are some "illegal" times, such as 14:73, 15:95, 12:74, 13:85, etc.

I am copy-pasting the monthly report for October 2018, so that you can see the weird times:

Temperature in C, Rain in MM, Wind Speed in KM/H and Pressure in HPA

AVG AVG DOM
DAY TEMP HIGH TIME LOW TIME RAIN WIND HIGH TIME DIR BAROM HUM
----------------------------------------------------------------------------------
01 25.1 31.9 13:33 20.1 07:84 0.2 3.6 24.1 15:24 302 1014.2 67
02 24.4 32.1 12:14 18.7 06:61 0.0 3.0 22.7 16:21 287 1016.3 67
03 23.9 32.8 13:55 18.7 03:24 0.0 4.8 27.4 16:40 270 1016.5 66
04 24.2 33.2 14:73 17.1 06:21 0.0 4.3 24.1 17:14 273 1015.7 62
05 26.4 33.1 15:95 20.4 05:91 0.0 3.3 22.5 18:43 289 1016.0 54
06 25.9 34.1 14:11 19.6 05:34 0.0 1.8 19.3 17:31 273 1014.4 50
07 24.9 32.9 13:24 18.4 06:41 0.0 2.1 22.5 18:14 271 1012.0 56
08 24.0 31.9 11:31 19.9 02:31 0.0 2.6 29.0 15:20 260 1011.9 65
09 21.7 30.0 12:44 18.6 22:71 2.2 1.1 19.4 11:83 271 1012.5 76
10 22.4 30.9 12:74 17.3 06:51 0.2 1.1 25.9 15:13 256 1013.0 72
11 23.2 32.3 14:21 17.3 06:40 0.0 0.1 17.7 13:20 216 1013.3 66
12 20.9 30.8 12:34 16.8 15:13 2.6 1.0 37.0 15:84 256 1013.5 71
13 20.5 27.1 12:42 15.6 07:83 0.2 0.8 22.5 13:14 160 1016.0 74
14 22.0 30.3 13:21 16.4 02:30 0.0 1.4 20.9 16:41 264 1015.6 67
15 22.6 29.5 14:75 17.7 05:44 0.0 1.0 25.7 17:05 274 1015.1 67
16 22.7 29.8 13:11 19.1 04:84 0.0 1.9 25.9 16:03 271 1014.8 72
17 22.3 29.7 12:70 18.0 07:53 1.2 0.1 17.7 16:23 243 1013.5 74
18 23.7 30.8 13:51 19.3 05:41 0.0 0.1 14.5 14:90 340 1012.3 71
19 24.4 32.3 14:23 18.7 07:34 0.0 0.3 14.5 14:15 288 1012.4 65
20 21.6 29.4 11:93 18.3 20:64 1.8 0.7 25.7 14:64 244 1012.6 77
21 21.1 29.0 13:55 17.2 05:11 1.2 1.0 27.4 15:23 228 1012.1 77
22 21.5 27.2 15:83 16.2 07:95 0.2 0.1 13.0 12:64 002 1014.9 75
23 22.7 28.9 13:50 18.2 05:31 0.2 1.3 19.4 14:85 071 1012.5 75
24 22.8 30.0 15:21 17.8 02:23 0.0 1.4 24.1 16:41 200 1007.2 69
25 19.4 25.0 13:41 14.9 23:63 1.8 6.4 37.1 13:91 268 1001.6 69
26 15.6 20.7 14:12 11.5 04:80 1.8 6.0 27.4 13:43 288 1012.4 61
27 17.1 24.0 14:94 11.2 07:25 0.0 1.7 17.7 11:14 110 1023.0 58
28 17.2 25.7 13:34 10.7 05:42 0.0 1.1 20.9 13:54 092 1024.5 60
29 18.5 27.8 13:53 11.7 02:22 0.0 0.1 16.1 11:61 102 1022.0 58
30 19.1 28.8 13:42 10.6 04:14 0.0 0.1 19.4 11:04 093 1021.3 50
31 20.0 30.3 13:85 12.6 05:95 0.0 0.0 11.3 12:80 155 1021.8 41
----------------------------------------------------------------------------------
MONTH 22.0 34.1 06 10.6 30 13.6 1.8 37.1 25 W 1014.7 66


Thanks,

chrysnic

Mattk
Platinum Boarder
Platinum Boarder
Posts: 738
Joined: Mon Sep 22, 2014 3:24 am

Re: Bug with times in NOAA-style reports

Post by Mattk » Wed Nov 28, 2018 1:07 pm

Change any of the minutes output like [wind0wind-maxts.lm: ] to [wind0wind-maxts.kl: ] and see what you get?

chrysnic
Senior Boarder
Senior Boarder
Posts: 73
Joined: Fri Apr 25, 2014 11:41 am

Re: Bug with times in NOAA-style reports

Post by chrysnic » Thu Nov 29, 2018 10:00 am

Indeed, replacing the ".lm" with ".kl" has fixed the issue with illegal times (i.e., times with numbers greater than 59 in the minutes field).

I assume that this will be fixed in all the NOAA templates in a future release, right?

Thanks for your time and help,

chrysnic

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5788
Joined: Mon Oct 01, 2007 10:51 pm

Re: Bug with times in NOAA-style reports

Post by admin » Sat Dec 01, 2018 9:19 pm

Good finding and Mattk's solution is 100% right. I fixed it in the templates of the just released update.

Post Reply