Page 1 of 1

Twitter Issues **solved**

Posted: Fri May 10, 2019 7:07 pm
by Patrick_UK
Is anybody else experiencing issues posting to Twitter?
Some days it has worked at hourly intervals and other days it might post once or twice and then not again for days.

Live data tab shows successful transfer to Twitter every hour.

Re: Twitter Issues

Posted: Sat May 11, 2019 8:23 am
by admin
Are you running the latest meteobridge version?

Re: Twitter Issues

Posted: Sat May 11, 2019 12:21 pm
by weerwantijdijk
Twitter is working fine over here: hourly tweets are still getting launched at my timeline.

Re: Twitter Issues

Posted: Sat May 11, 2019 3:10 pm
by Patrick_UK
Yes running V4 the latest one.

Re: Twitter Issues

Posted: Sun May 12, 2019 9:03 pm
by ConligWX
twitter working fine here every hour. using 3.9 and v4 now. (NANOSD)

maybe DNS issue? what DNS IPs are you using?

Re: Twitter Issues

Posted: Sat May 18, 2019 11:56 am
by Patrick_UK
Use the default BT hub ones.

Re: Twitter Issues

Posted: Sun May 19, 2019 8:45 am
by Patrick_UK
Also I have noticed that if I do a hard power down, when it comes back up it then will post once or twice then stop again.

Re: Twitter Issues

Posted: Mon May 27, 2019 2:29 pm
by Patrick_UK
Is there a way to see what the response is from Twitter, like in a log file?
As Live Data screen says successful but still not showing in the feed. Getting a new pin doesn't work either.
Tried deleting the service and restarting everything but still not working.

Re: Twitter Issues

Posted: Tue May 28, 2019 12:00 am
by ConligWX
you need to show what your posting ie
what message text is inside [ code ] [ / code]

This is mine:

Code: Select all

Time: [hh]:[mm] • Temp: [th0temp-act:--]°C • Wind: [wind0dir-act=endir:---] [wind0wind-act=mph.1:--] to [wind0wind-max10=mph.1:--]mph • Pressure: [thb0press-act:--]hPa • Rain: [rain0total-sumday]mm • Hum: [th0hum-act.0=:--]% • ET: [sol0evo-act.1=:--]mm • Solar: [sol0rad-act:--]W/m² • UV Index: [uv0index-act:--] • Sunrise: [mbsystem-sunrise:--] • Sunset: [mbsystem-sunset:--] • Cloudbase: #if#[th0temp-act.1:0.0]>[th0dew-act.1:0.0]#then#{*([th0temp-act.1:0.0]-[th0dew-act.1:0.0])*400*0}#else#0#fi#ft • #Conlig, #Bangor • bit.ly/2TzKYFb •

Re: Twitter Issues

Posted: Sat Jun 01, 2019 8:37 am
by Patrick_UK
It is very similar to yours, I got from a template post on here. (yours I think) :)

Code: Select all

Time: [hh]:[mm] • Temp: [th0temp-act:--]°C • Wind: [wind0dir-act=endir:---] [wind0wind-act=mph.1:--] to [wind0wind-max10=mph.1:--]mph • Pressure: [thb0seapress-act:--]hPa • Rain: [rain0total-sumday]mm • Hum: [th0hum-act.0=:--]% • ET: [sol0evo-act.1=:--]mm • Solar: [sol0rad-act:--]W/m² • UV Index: [uv0index-act:--] • Sunrise: [mbsystem-sunrise:--] • Sunset: [mbsystem-sunset:--] • Cloudbase: #if#[th0temp-act.1:0.0]>[th0dew-act.1:0.0]#then#{*([th0temp-act.1:0.0]-[th0dew-act.1:0.0])*400*0}#else#0#fi#ft • [forecast-text] #Dunstable

Re: Twitter Issues

Posted: Sun Jun 09, 2019 12:10 pm
by Patrick_UK
I have finally figured out the issue. It was to do with have [forecast-text] at the end, sometimes the forecast line pushes the tweet over the limit so it just doesn't post it. I thought twitter would cut off the extra characters but not!

Re: Twitter Issues

Posted: Sun Jun 09, 2019 5:32 pm
by admin
Thanks for letting us know. May be Meteobridge should cut the string? Is the limit you hit currently still 280?

Re: Twitter Issues

Posted: Sun Jun 09, 2019 9:08 pm
by ConligWX
Patrick_UK wrote:
Sun Jun 09, 2019 12:10 pm
I have finally figured out the issue. It was to do with have [forecast-text] at the end, sometimes the forecast line pushes the tweet over the limit so it just doesn't post it. I thought twitter would cut off the extra characters but not!
I created a separate entry for Weather Forecast which I post every 3 hours on twitter. so never experienced this issue.

Re: Twitter Issues

Posted: Thu Jun 13, 2019 1:25 pm
by Patrick_UK
That is what I resorted to as a test, but have kept it now.

Re: Twitter Issues

Posted: Thu Jun 13, 2019 1:26 pm
by Patrick_UK
admin wrote:
Sun Jun 09, 2019 5:32 pm
Thanks for letting us know. May be Meteobridge should cut the string? Is the limit you hit currently still 280?
Yes