Two systems lisning to the same weather station get different results **solved**

This section covers the Meteobridge PRO, NANO SD and Raspberry Pi units exclusively

Moderator: Mattk

DAP
Senior Boarder
Senior Boarder
Posts: 70
Joined: Fri Jan 15, 2016 8:37 am

Two systems lisning to the same weather station get different results **solved**

Post by DAP »

Last night, my physical manual rain gauge recorded 0.69" rain. I know this will be different from the Davis weather station because it is mounted in a different location at a different altitude, but I'm including it as a reference.

My Davis Vantage Pro 2 is showing 0.55" My Meteobridge PRO is transmitting data to WeatherUnderground It is showing 0.08" for yesterday and 0.39" for today for a sum total of 0.47" I can't see what the Meteobrige PRO recorded because it seems the graphing function is broken right now and won't show me a graph. I have rebooted to get the latest firmware and still can't get a graph.

https://www.wunderground.com/dashboard/ ... 1-27/daily
Since both of these systems are listening to the same physical rain gauge, they should have the same result.

Edit: Updating the firmware seems to have set my rainfall back to zero on WeatherUnderground. I don't ever recall this happening in the past.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 6631
Joined: Mon Oct 01, 2007 10:51 pm

Re: Two systems lisning to the same weather station get different results

Post by admin »

Your report does not make any sense to me. No error description I can work on, just a bunch of impressions. sorry.

Gyvate
Expert Boarder
Expert Boarder
Posts: 126
Joined: Thu May 14, 2020 4:36 pm

Re: Two systems lisning to the same weather station get different results

Post by Gyvate »

DAP wrote:
Wed Jan 27, 2021 9:38 pm
Last night, my physical manual rain gauge recorded 0.69" rain. I know this will be different from the Davis weather station because it is mounted in a different location at a different altitude, but I'm including it as a reference.

My Davis Vantage Pro 2 is showing 0.55" My Meteobridge PRO is transmitting data to WeatherUnderground It is showing 0.08" for yesterday and 0.39" for today for a sum total of 0.47" I can't see what the Meteobrige PRO recorded because it seems the graphing function is broken right now and won't show me a graph. I have rebooted to get the latest firmware and still can't get a graph.

https://www.wunderground.com/dashboard/ ... 1-27/daily
Since both of these systems are listening to the same physical rain gauge, they should have the same result.

Edit: Updating the firmware seems to have set my rainfall back to zero on WeatherUnderground. I don't ever recall this happening in the past.
you don't need a graph to see what MB Pro recorded - and stored in the database.
Depending on your selections, you will be able to see the minute or hourly data recorded from the sensors:
go to the history tab and select the sensor, the year, month and day and have a look into the table - it should be all there - no graph needed.
As sensor you should select rain0total. Then you will see in the history the amount of rainfall recorded in each hour.
You can also see it in the min/max section of the live data. It shows today, yesterday, month, year, all.

You should be a bit more verbose in the sense describing in detail what you wanted to do where and what didn't work the way you expected it. This is not really clear from your text.
WH4000SE 1.5.8/GW1000 1.6.6/HP1000SE Pro 1.7.1/WH2650 1.6.7-ß
2xMeteobridge Pro [B+R],RPi4-2/16
Ecowitt 5763, 5764; WU ISAARB3; ISAARB22; Weathercloud 3011399141; http://meshka.eu/meteo/template - http://meshka.eu/Weather34

Mattk
Platinum Boarder
Platinum Boarder
Posts: 885
Joined: Mon Sep 22, 2014 3:24 am

Re: Two systems lisning to the same weather station get different results

Post by Mattk »

One does not require a graph to know MBPro rainfall. How about outlining where your MBPro is reading the data from, direct from ISS or re-transmit?

DAP
Senior Boarder
Senior Boarder
Posts: 70
Joined: Fri Jan 15, 2016 8:37 am

Re: Two systems lisning to the same weather station get different results

Post by DAP »

Davis Vantage Pro2 is listning to the same RF signal as the Meteobridge PRO. I expect the recorded data transmitted to WheatherUnderground by the Meteobridge PRO to match exactly what is displayed by the Vantage Pro2 since they are recording exactly the same data. They do not match.

I don't expect the rainfall graph to suddenly drop to zero mid day when the Meteobridge PRO is reset, or there is a power outage (like occurred later in the day).

I expect the graph to work as it used to do on the meteobridge PRO, or instructions on how to make it work given I did noting to change its settings other than re-booting to update firmware. The graph is much easier to read and interpret than a table of numbers.

On the date in question, 2021-01-27 on the history page selecting "rain0total" I get "Sorry, No Results". In fact there are no results until about an hour ago when I adjusted the radio sensitivity as I have noticed some dropouts in the WeatherUnderground graphs. It seems the database is being wiped when the Meteobridge PRO is reset.

It also seems that the system keeps resetting some subsystems. Here are the logs:

Code: Select all

oled (28.01.2021 03:41:43): process started.
database (30.01.2021 21:52:31): process started.
database (30.01.2021 21:52:31): Content of RAM database restored.
database (30.01.2021 21:52:31): database sync done (0 tables, 0/0 writes).
wnetd  (30.01.2021 21:52:34): process started.
system (30.01.2021 21:52:34): start of logging process initiated.
wnetd  (30.01.2021 21:52:35): send data thread started (pid:2469 tid:2470)
logger (30.01.2021 21:52:35): databases connected. Update interval 3600 seconds.
logger (30.01.2021 21:52:35): data logger (version 5.1e, build 14306) started.
logger (30.01.2021 21:52:36): connect station 0 (Meteostick Vantage via USB serial).
logger (30.01.2021 21:52:36): connect station 9 (System Data via Plug-in).
logger (30.01.2021 21:52:38): station 0 (Meteostick Vantage), transmitter 2 registered as ISS
logger (30.01.2021 21:52:38): station 0 (Meteostick Vantage), Meteostick Version 2.5.2
logger (30.01.2021 21:52:38): station 0 (Meteostick Vantage), debug off
logger (30.01.2021 21:52:38): station 0 (Meteostick Vantage), verbose off
logger (30.01.2021 21:52:38): station 0 (Meteostick Vantage), output raw (8 bytes)
logger (30.01.2021 21:52:38): station 0 (Meteostick Vantage), output raw (10 bytes)
logger (30.01.2021 21:52:38): station 0 (Meteostick Vantage), filter on
logger (30.01.2021 21:52:38): station 0 (Meteostick Vantage), rx threshold set to -55db
logger (30.01.2021 21:52:38): station 0 (Meteostick Vantage), listening to transmitter 2
logger (30.01.2021 21:52:38): station 0 (Meteostick Vantage), bandwidth narrow
logger (30.01.2021 21:52:38): station 0 (Meteostick Vantage), chip authentication ok: 14
logger (30.01.2021 21:52:38): station 0 (Meteostick Vantage), frequency band 915MHz (US)
logger (30.01.2021 21:52:39): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (30.01.2021 21:52:39): services paused.
logger (30.01.2021 21:54:36): give up waiting for sensors after 120 secs.
logger (30.01.2021 21:54:36): services activated.
system (31.01.2021 05:55:24): stop of logging process initiated.
logger (30.01.2021 21:55:24): parent process received termination signal (15).
logger (30.01.2021 21:55:24): child process received termination signal (15).
logger (30.01.2021 21:55:24): disconnect station 0 (Meteostick Vantage): exit
logger (30.01.2021 21:55:24): disconnect station 9 (System Data): exit
database (30.01.2021 21:55:25): process terminated normally.
test5m (31.01.2021 05:55:26): USB storage remounted: /dev/sda
database (30.01.2021 21:55:26): process started.
system (31.01.2021 05:55:26): start of logging process initiated.
logger (30.01.2021 21:55:27): databases connected. Update interval 3600 seconds.
logger (30.01.2021 21:55:27): data logger (version 5.1e, build 14306) started.
logger (30.01.2021 21:55:29): connect station 0 (Meteostick Vantage via USB serial).
logger (30.01.2021 21:55:29): connect station 9 (System Data via Plug-in).
database (30.01.2021 21:55:30): database sync done (33 tables, 165/165 writes).
logger (30.01.2021 21:55:31): station 0 (Meteostick Vantage), transmitter 2 registered as ISS
logger (30.01.2021 21:55:31): station 0 (Meteostick Vantage), Meteostick Version 2.5.2
logger (30.01.2021 21:55:31): station 0 (Meteostick Vantage), debug off
logger (30.01.2021 21:55:31): station 0 (Meteostick Vantage), verbose off
logger (30.01.2021 21:55:31): station 0 (Meteostick Vantage), output raw (8 bytes)
logger (30.01.2021 21:55:31): station 0 (Meteostick Vantage), output raw (10 bytes)
logger (30.01.2021 21:55:31): station 0 (Meteostick Vantage), filter on
logger (30.01.2021 21:55:31): station 0 (Meteostick Vantage), rx threshold set to -55db
logger (30.01.2021 21:55:31): station 0 (Meteostick Vantage), listening to transmitter 2
logger (30.01.2021 21:55:31): station 0 (Meteostick Vantage), bandwidth narrow
logger (30.01.2021 21:55:31): station 0 (Meteostick Vantage), chip authentication ok: 14
logger (30.01.2021 21:55:31): station 0 (Meteostick Vantage), frequency band 915MHz (US)
logger (30.01.2021 21:55:32): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (30.01.2021 21:55:32): services paused.
system (30.01.2021 21:56:41): stop of logging process initiated.
logger (30.01.2021 21:56:41): parent process received termination signal (15).
logger (30.01.2021 21:56:41): child process received termination signal (15).
logger (30.01.2021 21:56:41): disconnect station 0 (Meteostick Vantage): exit
logger (30.01.2021 21:56:41): disconnect station 9 (System Data): exit
database (30.01.2021 21:56:42): process terminated normally.
test5m (30.01.2021 21:56:43): USB storage remounted: /dev/sda
database (30.01.2021 21:56:44): process started.
system (30.01.2021 21:56:44): start of logging process initiated.
logger (30.01.2021 21:56:44): databases connected. Update interval 3600 seconds.
logger (30.01.2021 21:56:44): data logger (version 5.1e, build 14306) started.
logger (30.01.2021 21:56:46): connect station 0 (Meteostick Vantage via USB serial).
logger (30.01.2021 21:56:46): connect station 9 (System Data via Plug-in).
database (30.01.2021 21:56:47): database sync done (33 tables, 0/165 writes).
logger (30.01.2021 21:56:48): station 0 (Meteostick Vantage), transmitter 2 registered as ISS
logger (30.01.2021 21:56:48): station 0 (Meteostick Vantage), Meteostick Version 2.5.2
logger (30.01.2021 21:56:48): station 0 (Meteostick Vantage), debug off
logger (30.01.2021 21:56:48): station 0 (Meteostick Vantage), verbose off
logger (30.01.2021 21:56:48): station 0 (Meteostick Vantage), output raw (8 bytes)
logger (30.01.2021 21:56:48): station 0 (Meteostick Vantage), output raw (10 bytes)
logger (30.01.2021 21:56:48): station 0 (Meteostick Vantage), filter on
logger (30.01.2021 21:56:48): station 0 (Meteostick Vantage), rx threshold set to -55db
logger (30.01.2021 21:56:48): station 0 (Meteostick Vantage), listening to transmitter 2
logger (30.01.2021 21:56:48): station 0 (Meteostick Vantage), bandwidth narrow
logger (30.01.2021 21:56:49): station 0 (Meteostick Vantage), chip authentication ok: 14
logger (30.01.2021 21:56:49): station 0 (Meteostick Vantage), frequency band 915MHz (US)
logger (30.01.2021 21:56:50): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (30.01.2021 21:56:50): services paused.
logger (30.01.2021 21:58:47): give up waiting for sensors after 120 secs.
logger (30.01.2021 21:58:47): services activated.
system (31.01.2021 06:00:41): stop of logging process initiated.
logger (30.01.2021 22:00:41): parent process received termination signal (15).
logger (30.01.2021 22:00:41): child process received termination signal (15).
logger (30.01.2021 22:00:41): disconnect station 0 (Meteostick Vantage): exit
logger (30.01.2021 22:00:41): disconnect station 9 (System Data): exit
database (30.01.2021 22:00:42): process terminated normally.
test5m (31.01.2021 06:00:43): USB storage remounted: /dev/sda
database (30.01.2021 22:00:43): process started.
system (31.01.2021 06:00:43): start of logging process initiated.
logger (30.01.2021 22:00:44): databases connected. Update interval 3600 seconds.
logger (30.01.2021 22:00:44): data logger (version 5.1e, build 14306) started.
logger (30.01.2021 22:00:46): connect station 0 (Meteostick Vantage via USB serial).
logger (30.01.2021 22:00:46): connect station 9 (System Data via Plug-in).
database (30.01.2021 22:00:47): database sync done (39 tables, 0/195 writes).
logger (30.01.2021 22:00:48): station 0 (Meteostick Vantage), transmitter 2 registered as ISS
logger (30.01.2021 22:00:48): station 0 (Meteostick Vantage), Meteostick Version 2.5.2
logger (30.01.2021 22:00:48): station 0 (Meteostick Vantage), debug off
logger (30.01.2021 22:00:48): station 0 (Meteostick Vantage), verbose off
logger (30.01.2021 22:00:48): station 0 (Meteostick Vantage), output raw (8 bytes)
logger (30.01.2021 22:00:48): station 0 (Meteostick Vantage), output raw (10 bytes)
logger (30.01.2021 22:00:48): station 0 (Meteostick Vantage), filter on
logger (30.01.2021 22:00:48): station 0 (Meteostick Vantage), rx threshold set to -55db
logger (30.01.2021 22:00:48): station 0 (Meteostick Vantage), listening to transmitter 2
logger (30.01.2021 22:00:48): station 0 (Meteostick Vantage), bandwidth narrow
logger (30.01.2021 22:00:49): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (30.01.2021 22:00:49): services paused.
logger (30.01.2021 22:00:49): station 0 (Meteostick Vantage), chip authentication ok: 14
logger (30.01.2021 22:00:49): station 0 (Meteostick Vantage), frequency band 915MHz (US)
logger (30.01.2021 22:02:46): give up waiting for sensors after 120 secs.
logger (30.01.2021 22:02:46): services activated.
system (31.01.2021 06:05:34): stop of logging process initiated.
logger (30.01.2021 22:05:34): parent process received termination signal (15).
logger (30.01.2021 22:05:34): child process received termination signal (15).
logger (30.01.2021 22:05:34): disconnect station 0 (Meteostick Vantage): exit
logger (30.01.2021 22:05:34): disconnect station 9 (System Data): exit
database (30.01.2021 22:05:35): process terminated normally.
test5m (31.01.2021 06:05:36): USB storage remounted: /dev/sda
database (30.01.2021 22:05:36): process started.
system (31.01.2021 06:05:36): start of logging process initiated.
logger (30.01.2021 22:05:37): databases connected. Update interval 3600 seconds.
logger (30.01.2021 22:05:37): data logger (version 5.1e, build 14306) started.
logger (30.01.2021 22:05:39): connect station 0 (Meteostick Vantage via USB serial).
logger (30.01.2021 22:05:39): connect station 9 (System Data via Plug-in).
database (30.01.2021 22:05:41): database sync done (46 tables, 166/269 writes).
logger (30.01.2021 22:05:41): station 0 (Meteostick Vantage), transmitter 2 registered as ISS
logger (30.01.2021 22:05:41): station 0 (Meteostick Vantage), Meteostick Version 2.5.2
logger (30.01.2021 22:05:41): station 0 (Meteostick Vantage), debug off
logger (30.01.2021 22:05:41): station 0 (Meteostick Vantage), verbose off
logger (30.01.2021 22:05:41): station 0 (Meteostick Vantage), output raw (8 bytes)
logger (30.01.2021 22:05:41): station 0 (Meteostick Vantage), output raw (10 bytes)
logger (30.01.2021 22:05:41): station 0 (Meteostick Vantage), filter on
logger (30.01.2021 22:05:41): station 0 (Meteostick Vantage), rx threshold set to -55db
logger (30.01.2021 22:05:41): station 0 (Meteostick Vantage), listening to transmitter 2
logger (30.01.2021 22:05:41): station 0 (Meteostick Vantage), bandwidth narrow
logger (30.01.2021 22:05:42): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (30.01.2021 22:05:42): services paused.
logger (30.01.2021 22:05:42): station 0 (Meteostick Vantage), chip authentication ok: 14
logger (30.01.2021 22:05:42): station 0 (Meteostick Vantage), frequency band 915MHz (US)
logger (30.01.2021 22:06:43): sensors are now providing data.
logger (30.01.2021 22:06:43): services started.
system (31.01.2021 06:10:07): stop of logging process initiated.
logger (30.01.2021 22:10:07): parent process received termination signal (15).
logger (30.01.2021 22:10:07): child process received termination signal (15).
logger (30.01.2021 22:10:07): disconnect station 0 (Meteostick Vantage): exit
logger (30.01.2021 22:10:07): disconnect station 9 (System Data): exit
database (30.01.2021 22:10:08): process terminated normally.
test5m (31.01.2021 06:10:09): USB storage remounted: /dev/sda
database (30.01.2021 22:10:09): process started.
system (31.01.2021 06:10:09): start of logging process initiated.
logger (30.01.2021 22:10:10): databases connected. Update interval 3600 seconds.
logger (30.01.2021 22:10:10): data logger (version 5.1e, build 14306) started.
logger (30.01.2021 22:10:12): connect station 0 (Meteostick Vantage via USB serial).
logger (30.01.2021 22:10:12): connect station 9 (System Data via Plug-in).
logger (30.01.2021 22:10:14): station 0 (Meteostick Vantage), transmitter 2 registered as ISS
logger (30.01.2021 22:10:14): station 0 (Meteostick Vantage), Meteostick Version 2.5.2
logger (30.01.2021 22:10:14): station 0 (Meteostick Vantage), debug off
logger (30.01.2021 22:10:14): station 0 (Meteostick Vantage), verbose off
logger (30.01.2021 22:10:14): station 0 (Meteostick Vantage), output raw (8 bytes)
logger (30.01.2021 22:10:14): station 0 (Meteostick Vantage), output raw (10 bytes)
logger (30.01.2021 22:10:14): station 0 (Meteostick Vantage), filter on
logger (30.01.2021 22:10:14): station 0 (Meteostick Vantage), rx threshold set to -55db
logger (30.01.2021 22:10:14): station 0 (Meteostick Vantage), listening to transmitter 2
logger (30.01.2021 22:10:14): station 0 (Meteostick Vantage), bandwidth narrow
database (30.01.2021 22:10:14): database sync done (46 tables, 127/269 writes).
logger (30.01.2021 22:10:14): station 0 (Meteostick Vantage), chip authentication ok: 14
logger (30.01.2021 22:10:14): station 0 (Meteostick Vantage), frequency band 915MHz (US)
logger (30.01.2021 22:10:15): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (30.01.2021 22:10:15): services paused.
logger (30.01.2021 22:12:12): give up waiting for sensors after 120 secs.
logger (30.01.2021 22:12:12): services activated.
system (31.01.2021 06:16:21): stop of logging process initiated.
logger (30.01.2021 22:16:21): parent process received termination signal (15).
logger (30.01.2021 22:16:21): child process received termination signal (15).
logger (30.01.2021 22:16:21): disconnect station 0 (Meteostick Vantage): exit
logger (30.01.2021 22:16:21): disconnect station 9 (System Data): exit
database (30.01.2021 22:16:22): process terminated normally.
test5m (31.01.2021 06:16:23): USB storage remounted: /dev/sda
database (30.01.2021 22:16:23): process started.
system (31.01.2021 06:16:23): start of logging process initiated.
logger (30.01.2021 22:16:24): databases connected. Update interval 3600 seconds.
logger (30.01.2021 22:16:24): data logger (version 5.1e, build 14306) started.
logger (30.01.2021 22:16:26): connect station 0 (Meteostick Vantage via USB serial).
logger (30.01.2021 22:16:26): connect station 9 (System Data via Plug-in).
logger (30.01.2021 22:16:28): station 0 (Meteostick Vantage), transmitter 2 registered as ISS
logger (30.01.2021 22:16:28): station 0 (Meteostick Vantage), Meteostick Version 2.5.2
logger (30.01.2021 22:16:28): station 0 (Meteostick Vantage), debug off
logger (30.01.2021 22:16:28): station 0 (Meteostick Vantage), verbose off
logger (30.01.2021 22:16:28): station 0 (Meteostick Vantage), output raw (8 bytes)
logger (30.01.2021 22:16:28): station 0 (Meteostick Vantage), output raw (10 bytes)
logger (30.01.2021 22:16:28): station 0 (Meteostick Vantage), filter on
logger (30.01.2021 22:16:28): station 0 (Meteostick Vantage), rx threshold set to -55db
logger (30.01.2021 22:16:28): station 0 (Meteostick Vantage), listening to transmitter 2
logger (30.01.2021 22:16:28): station 0 (Meteostick Vantage), bandwidth narrow
database (30.01.2021 22:16:28): database sync done (46 tables, 150/269 writes).
logger (30.01.2021 22:16:28): station 0 (Meteostick Vantage), chip authentication ok: 14
logger (30.01.2021 22:16:28): station 0 (Meteostick Vantage), frequency band 915MHz (US)
logger (30.01.2021 22:16:29): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (30.01.2021 22:16:29): services paused.
logger (30.01.2021 22:17:29): sensors are now providing data.
logger (30.01.2021 22:17:29): services started.

Mattk
Platinum Boarder
Platinum Boarder
Posts: 885
Joined: Mon Sep 22, 2014 3:24 am

Re: Two systems lisning to the same weather station get different results

Post by Mattk »

What sort of distance and barriers do you have between the MBPro and the ISS? What was/is your Sensitivity value?

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 6631
Joined: Mon Oct 01, 2007 10:51 pm

Re: Two systems lisning to the same weather station get different results

Post by admin »

DAP wrote:
Sun Jan 31, 2021 8:00 am
I don't expect the rainfall graph to suddenly drop to zero mid day when the Meteobridge PRO is reset, or there is a power outage (like occurred later in the day).
Meteobridge PRO updates the database on USB storage for storing data long term every hour. When a regular reboot is done, sub hour data just hold in RAM is written to USB storage to reload from there on boot. This remains true even if you have activated per-minute data storing which stores data to be used for graphs etc but does not synchronize with data aggregation processes on reboot. It is kept completely seperate just used for graphing and data exports.

Having that said, when you do a hard reset (power-cycle or alike) you will loose up to an hour of data and by that rain totals can differ.

DAP
Senior Boarder
Senior Boarder
Posts: 70
Joined: Fri Jan 15, 2016 8:37 am

Re: Two systems lisning to the same weather station get different results

Post by DAP »

I had not reset the Meteobridge pro before I noticed the discrepancy between the WeatherUnderground data and the Vantage PRO2 data.
When I did reset the Meteobridge PRO, it deleted at least 11 hours of rainfall accumulation the first time, and 6 hours of rainfall accumulation the second time. Please look at the data on WeatherUnderground for January 27: https://www.wunderground.com/dashboard/ ... 1-27/daily

Both the Davis Vantage Pro 2 and the Meteobridge PRO are within 6" of each other. They are separated from the weather station by a plaster board ceiling, composition shingles, a layer of tar paper, and a layer of 1/2" fiber board.

The power readings are about -43 dB. The receiver sensitivity setting previously was -60dB, I changed that to -55dB to see if it would improve the reception and eliminate the dropouts.

Given the log files report that it is restarting the USB storage, I am beginning to believe that the USB memory stick is warn out (again).
Is it possible to replace that memory stick and have the Meteobridge pro continue to work? Is there some kind of security key stored on the memory stick? Is there a size limitation? It might make sense to replace it with an uSD card reader, and a uSD card designed to be used in dash-cams. This might last longer than a USB memory stick. (many people are using these in Tesla cars and having better success than memory sticks. An SSD would be better, but those may be bigger than what the Meteobridge pro can handle, and certainly would not fit in the case).

User avatar
galfert
Platinum Boarder
Platinum Boarder
Posts: 326
Joined: Sun Jun 24, 2018 10:31 pm
Location: Orlando, FL

Re: Two systems lisning to the same weather station get different results

Post by galfert »

There is a setting in the Meteobridge PRO to designate what type of rain spoon tipper you have, inches or mm. You need to match what you actually have in the hardware. The same configuration option is part of the setup on the display console.
Meteobridge RPI | GW1000

Mattk
Platinum Boarder
Platinum Boarder
Posts: 885
Joined: Mon Sep 22, 2014 3:24 am

Re: Two systems lisning to the same weather station get different results

Post by Mattk »

What USB memory sticks are you and have you been using? Ordinary everyday flash drives will not last all that long and are a waste of time. The USB flash stick needs to be an industrial grade SLC, you will take quite a few years to ever wear these out.

DAP
Senior Boarder
Senior Boarder
Posts: 70
Joined: Fri Jan 15, 2016 8:37 am

Re: Two systems lisning to the same weather station get different results

Post by DAP »

galfert wrote:
Sun Jan 31, 2021 10:20 pm
There is a setting in the Meteobridge PRO to designate what type of rain spoon tipper you have, inches or mm. You need to match what you actually have in the hardware. The same configuration option is part of the setup on the display console.
It is, and has been set correctly for years. This discrepancy is a new thing.
Mattk wrote:
Mon Feb 01, 2021 10:46 am
What USB memory sticks are you and have you been using? Ordinary everyday flash drives will not last all that long and are a waste of time. The USB flash stick needs to be an industrial grade SLC, you will take quite a few years to ever wear these out.
I am using the one that is built into the meteobridge pro. I have not yet opened the case to see what came with the unit. I just know that I had to send back my first unit because the USB memory failed. Now it is long out of warrantee, so I will be fixing it myself if I can.

DAP
Senior Boarder
Senior Boarder
Posts: 70
Joined: Fri Jan 15, 2016 8:37 am

Re: Two systems lisning to the same weather station get different results

Post by DAP »

My meteobridge PRO is definitely malfunctioning. Today the Davis has recorded 0.17" rain, WeatherUnderground only shows 0.4" Also, it is showing a rain rate with no actual rain.

I just checked the Meteobridge PRO history tab. I verified that the rain gauge setting is 0.01" per bucket dump. History is showing data in mm.
It is showing .6mm at 4:AM, .3mm at 5 AM, and .8 at 8AM. I can't figure out a way that this correlates to the 0.4" that WeatherUnderground is showing, or the 0.19" that Davis is currently showing.

Log shows it restarting the USB storage and radio about every 5 minutes.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 6631
Joined: Mon Oct 01, 2007 10:51 pm

Re: Two systems lisning to the same weather station get different results

Post by admin »

can you please provide me a remote login? Please mail credentials to "info(at)meteobridge.com".

DAP
Senior Boarder
Senior Boarder
Posts: 70
Joined: Fri Jan 15, 2016 8:37 am

Re: Two systems lisning to the same weather station get different results

Post by DAP »

I will get you login info shortly.
I disassembled the meteobridge PRO and pulled the Toshiba 8GB USB drive. I plugged it into my linux system, and it reported it was unable to mount the disk due to a bad superblock. I attempted to look at the disk with the "Disks" application. It reported an ext4 file system. I attempted to check the disk, and it claimed that there was no file system on the disk, and "Disks" change to report no filesytem instead of ext4.
Unless this thumb drive has a proprietary format, I think this thumb drive is beyond recovery.

I will now put the system back together so I can get you a login.
edit: login credentials sent.

I just checked my junk drawer and found a working USB uSD card reader that is small enough to fit in the available space (smaller than the existing drive). I also have uSD cards on hand that I could use until I can buy a High Endurance uSD card. Anything I need to know about formatting the card? I'd just assume I could format it to ext4, and assume it can handle larger disks than 8GB.

DAP
Senior Boarder
Senior Boarder
Posts: 70
Joined: Fri Jan 15, 2016 8:37 am

Re: Two systems lisning to the same weather station get different results

Post by DAP »

According to a discussion in e-mail, I should be able to replace the USB memory stick with a new one, and it should be partitioned and formatted automatically.

I have now tried 3 different memory sticks with no luck. The LED on the memory stick lights up and flashes to indicate activity, but I get the same restart in my logs as in an earlier post. I pull the stick and look at it on my computer and the old data is still there. It has not been partitioned or re-formatted.

I tried putting the stick in the front USB port, and I also see activity on the LEDs, but it also does not write to the memory stick. I do get different messages in the log. This time about the database disk being full, but nothing is every written.

I'm beginning to think my meteobridge PRO is dead.

Post Reply