Template problems

This section covers the Meteobridge PRO, NANO SD and Raspberry Pi units exclusively

Moderator: Mattk

Post Reply
IVD
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Thu Dec 19, 2019 11:52 am

Template problems

Post by IVD »

Hello,

I am writing a template to collect yearly data and have discovered a few problems I hope somebody will be able to help me with.

[th0temp-ymin.1: ] returns the all-time minimum no matter what year I explore while at the same time [th0temp-ymintime.gh: ]/[th0temp-ymintime.ef: ] returns the correct date the mimum temperature occured in each year I am exploring. I have no problems with the yearly average or max or the min for other parameters.

[wind0maxdir-max.0:-] returns the correct value in degrees of the wind direction in each month or each day. However, [wind0maxdir-ymax.0:-] does not return the value in degrees of the maximum wind gust of the year. It simple gives the highest value of wind gust max measured. For example, the highest wind gust of 60 mph was measured in February and had a direction of 234° but January had a max wind gust of only 40 mph from the direction 356° and [wind0maxdir-ymax.0:-] returns the value of 356 and not 234°, which is the direction of the highest wind gust of the year.

What am I doing wrong?

regards

hymrog
Senior Boarder
Senior Boarder
Posts: 54
Joined: Sat Feb 01, 2014 1:25 am
Contact:

Re: Template problems

Post by hymrog »

Hello -

Although you dont state what platform you are using I am thinking this will get you what you are looking for the temps:

Code: Select all

[th0temp-min@Y1=F]%20[th0temp-mintime@Y1.gh]%20[th0temp-mintime@Y1.ef]
and you would use something similar for your wind data:

Code: Select all

[wind0maxdir-max@M1]
Have a read here under the Metebridge PRO Additons:

https://www.meteobridge.com/wiki/index.php/Templates

g

IVD
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Thu Dec 19, 2019 11:52 am

Re: Template problems

Post by IVD »

Hello,

Thanks for your help.
[th0temp-min@2020],[th0temp-mintime@2020.gh]/[th0temp-mintime@2020.ef] and [wind0maxdir-max@2020] give me the correct data for 2020 so I can adjust this for any year I need.

I am using Meteobrige NanoSD and I was not aware that I could use the specific additions for PRO (I thought they would not work for Nano SD).

regards

Post Reply