No data after firmware update. **solved**

This section covers the Meteobridge PRO, NANO SD and Raspberry Pi units exclusively

Moderator: Mattk

Post Reply
Asobig
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Fri Dec 23, 2016 5:01 pm

No data after firmware update. **solved**

Post by Asobig »

This morning i restarted the Meteobridge Pro.
It booted, but there is no data coming in.
I use a Davis Envoy 8x.
In the log i see this:
logger (10.03.2021 08:42:47): databases connected. Update interval 3600 seconds.
logger (10.03.2021 08:42:47): data logger (version 5.1e, build 14348) started.
logger (10.03.2021 08:42:48): connect station 0 (Envoy 8x via USB serial).
logger (10.03.2021 08:42:48): connect station 9 (System Data via Plug-in).
logger (10.03.2021 08:42:49): station 0 (Envoy 8x), wakeup sent.
logger (10.03.2021 08:42:49): station 0 (Envoy 8x), internal logger activated.
logger (10.03.2021 08:42:49): station 0 (Envoy 8x), syncing.
logger (10.03.2021 08:42:52): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (10.03.2021 08:42:52): services paused.
logger (10.03.2021 08:42:59): station 0 (Envoy 8x), gettime request sent.
logger (10.03.2021 08:42:59): station 0 (Envoy 8x), time offset of Envoy8x: -159 minutes
logger (10.03.2021 08:42:59): station 0 (Envoy 8x), eeprom request sent.
logger (10.03.2021 08:42:59): station 0 (Envoy 8x), envoy8x ID: 2
logger (10.03.2021 08:42:59): station 0 (Envoy 8x), channel 1 is "Vantage Pro 2 Plus ISS": 0.2 mm per rain tick
logger (10.03.2021 08:42:59): station 0 (Envoy 8x), channel 2 is "Leaf/Soil Station"
logger (10.03.2021 08:43:01): child process received termination signal (11) in functions: termination_handler < update_persist < get_set < get_set < get_set < calibrate_store < update_persist_float < write_persist < print_virtual_sensor < pipeoutstr < get_set < get_set < get_set < calibrate_store < setup_pipe < get_sensorid < print_num_sensor < sensor_copy < set_vsensor < set_sensor < g...
logger (10.03.2021 08:43:01): disconnect station 0 (Envoy 8x): exit
logger (10.03.2021 08:43:01): disconnect station 9 (System Data): exit
logger (10.03.2021 08:43:02): data logger stopped.
logger (10.03.2021 08:43:02): databases disconnected.
logger (10.03.2021 08:43:02): parent process to be terminated.

azchrisf
Senior Boarder
Senior Boarder
Posts: 40
Joined: Thu Aug 17, 2017 5:30 am

Re: No data after firmware update

Post by azchrisf »

Same here. Appears to be a bug introduced. I Emailed Boris.

feo_santaCruz
Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Wed Mar 10, 2021 10:27 am

Re: No data after firmware update

Post by feo_santaCruz »

same with meteostick and davis vantagep2. To save/backup the database is also not possible, e.g. the initiated prozess shows no result in the backup-folder of meteobridge

greets
Frank

cwmalmanac
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Wed Mar 10, 2021 11:42 am

Re: No data after firmware update

Post by cwmalmanac »

Hi, just joined after recently buying an MB Pro and new Davis VP2. This morning the small display is showing the IP address view followed by two parallel bars that move slowly together. The red LED is permanently on. Reboot does not fix. Like reported by others already, my logs show this repeating every 20mins:

logger (10.03.2021 09:16:17): disconnect station 0 (Meteostick Vantage): exit
logger (10.03.2021 09:26:47): child process received timeout signal (14).
logger (10.03.2021 09:26:47): disconnect station 9 (System Data): exit
logger (10.03.2021 09:26:49): data logger stopped.
logger (10.03.2021 09:26:49): databases disconnected.
logger (10.03.2021 09:26:49): parent process to be terminated.
logger (10.03.2021 09:26:49): databases connected. Update interval 3600 seconds.
logger (10.03.2021 09:26:49): data logger (version 5.1e, build 14348) started.
logger (10.03.2021 09:26:50): connect station 0 (Meteostick Vantage via USB serial).
logger (10.03.2021 09:26:50): connect station 9 (System Data via Plug-in).
logger (10.03.2021 09:26:50): station 0 (Meteostick Vantage), transmitter 1 registered as ISS
logger (10.03.2021 09:26:50): station 0 (Meteostick Vantage), Meteostick Version 2.5.2
logger (10.03.2021 09:26:50): station 0 (Meteostick Vantage), debug off
logger (10.03.2021 09:26:50): station 0 (Meteostick Vantage), verbose off
logger (10.03.2021 09:26:50): station 0 (Meteostick Vantage), output raw (8 bytes)
logger (10.03.2021 09:26:50): station 0 (Meteostick Vantage), output raw (10 bytes)
logger (10.03.2021 09:26:50): station 0 (Meteostick Vantage), filter on
logger (10.03.2021 09:26:50): station 0 (Meteostick Vantage), rx threshold set to -90db
logger (10.03.2021 09:26:50): station 0 (Meteostick Vantage), listening to transmitter 1
logger (10.03.2021 09:26:50): station 0 (Meteostick Vantage), bandwidth narrow
logger (10.03.2021 09:26:51): station 0 (Meteostick Vantage), chip authentication ok: 14
logger (10.03.2021 09:26:51): station 0 (Meteostick Vantage), frequency band 868MHz (EU)
logger (10.03.2021 09:26:53): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (10.03.2021 09:26:53): services paused.
logger (10.03.2021 09:27:01): child process received termination signal (11) in functions: termination_handler < update_persist < get_set < get_set < get_set < calibrate_store < update_persist_float < write_persist < print_virtual_sensor < pipeoutstr < get_set < get_set < get_set < calibrate_store < setup_pipe < get_sensorid < print_num_sensor < sensor_copy < set_vsensor < set_sensor < g...
logger (10.03.2021 09:27:01): disconnect station 0 (Meteostick Vantage): exit

Mattk
Platinum Boarder
Platinum Boarder
Posts: 885
Joined: Mon Sep 22, 2014 3:24 am

Re: No data after firmware update

Post by Mattk »

cwmalmanac wrote:
Wed Mar 10, 2021 11:47 am
.... This morning the small display is showing the IP address view followed by two parallel bars that move slowly together....
When you have some free time take a look through the release index https://www.meteobridge.com/wiki/index.php/Forum

In regard the moving bars etc check Version 3.2 release May 26, 2017 for specific info on that.

cwmalmanac
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Wed Mar 10, 2021 11:42 am

Re: No data after firmware update

Post by cwmalmanac »

Thank you @Mattk I have read that now.

I noticed at 15:35 hrs (UTC+0), that the MB Pro is now working as expected, without any intervention by me since I posted 6 hours ago. My logging screen shows:

oled (10.03.2021 06:11:52): process started.
database (10.03.2021 12:44:05): process started.
database (10.03.2021 12:44:05): Content of RAM database restored.
wnetd (10.03.2021 12:44:07): process started.
system (10.03.2021 12:44:07): start of logging process initiated.
wnetd (10.03.2021 12:44:08): send data thread started (pid:2419 tid:2420)
logger (10.03.2021 12:44:08): databases connected. Update interval 3600 seconds.
logger (10.03.2021 12:44:08): data logger (version 5.1e, build 14349) started.
logger (10.03.2021 12:44:09): connect station 0 (Meteostick Vantage via USB serial).
logger (10.03.2021 12:44:09): connect station 9 (System Data via Plug-in).
logger (10.03.2021 12:44:13): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (10.03.2021 12:44:13): services paused.
logger (10.03.2021 12:44:13): station 0 (Meteostick Vantage), transmitter 1 registered as ISS
logger (10.03.2021 12:44:13): station 0 (Meteostick Vantage), Meteostick Version 2.5.2
logger (10.03.2021 12:44:13): station 0 (Meteostick Vantage), debug off
logger (10.03.2021 12:44:13): station 0 (Meteostick Vantage), verbose off
logger (10.03.2021 12:44:13): station 0 (Meteostick Vantage), output raw (8 bytes)
logger (10.03.2021 12:44:13): station 0 (Meteostick Vantage), output raw (10 bytes)
logger (10.03.2021 12:44:13): station 0 (Meteostick Vantage), filter on
logger (10.03.2021 12:44:13): station 0 (Meteostick Vantage), rx threshold set to -90db
logger (10.03.2021 12:44:13): station 0 (Meteostick Vantage), listening to transmitter 1
logger (10.03.2021 12:44:13): station 0 (Meteostick Vantage), bandwidth narrow
logger (10.03.2021 12:44:13): station 0 (Meteostick Vantage), chip authentication ok: 14
logger (10.03.2021 12:44:13): station 0 (Meteostick Vantage), frequency band 868MHz (EU)
database (10.03.2021 12:44:22): database sync done (41 tables, 0/1602 writes).
logger (10.03.2021 12:46:10): give up waiting for sensors after 120 secs.
logger (10.03.2021 12:46:10): services activated.

Charts show no data from about midnight to about 12:445 (UTC+0) - chart attached. I hope this information is helpful to others.
chart-20210310-1645.png
chart-20210310-1645.png (99.1 KiB) Viewed 296 times

Mattk
Platinum Boarder
Platinum Boarder
Posts: 885
Joined: Mon Sep 22, 2014 3:24 am

Re: No data after firmware update

Post by Mattk »

That may be an interest connection issue during startup/reboot?

Asobig
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Fri Dec 23, 2016 5:01 pm

Re: No data after firmware update

Post by Asobig »

THERE IS AN UPDATE AVAILABLE.
I just rebooted the Meteobridge and it is working again!!!

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 6631
Joined: Mon Oct 01, 2007 10:51 pm

Re: No data after firmware update

Post by admin »

sorry for the glitch.

Post Reply