Samba shares no longer available after Win10 update (fixed)

Discussion of the Meteohub software package

Moderator: Mattk

Post Reply
TomS
Fresh Boarder
Fresh Boarder
Posts: 15
Joined: Thu Apr 09, 2015 5:21 pm

Samba shares no longer available after Win10 update (fixed)

Post by TomS »

I can no longer get to the samba shares on my meteohub (raspberry pi) from Windows 10 after a recent update.

Browsing to the share (\\192.168.5.xx) in windows explorer gives a generic "cannot connect" error, but trying to mount it to a drive letter gives a more specific message:

======
You can't connect to the file share because it's not secure. This share requires the obsolete SMB1 protocol, which is unsafe and could expose your system to attack.
Your system requires SMB2 or higher. For more info on resolving this issue, see: https://go.microsoft.com/fwlink/?linkid=852747
======

Going to that microsoft URL talks in detail about this.

I did fix it by adding back in support for SMB1 protocol (in the "Turn Windows Features on or off" part of the Add/Remove Programs dialog).

What's the chance of updating the meteohub app to smbv2?

Tom

User avatar
galfert
Gold Boarder
Gold Boarder
Posts: 308
Joined: Sun Jun 24, 2018 10:31 pm
Location: Orlando, FL

Re: Samba shares no longer available after Win10 update (fixed)

Post by galfert »

TomS wrote:
Tue Feb 27, 2018 5:38 pm
What's the chance of updating the meteohub app to smbv2?
Good information find! The statement from Smartbedded is that Meteohub development is stopped. The recommendation is to migrate to Meteobridge. The Meteobridge on Raspberry Pi hardware is a very compelling upgrade.

I realize this is a an old thread but it was recently used as a forward link to a new thread that was in need of a solution.
Meteobridge RPI | GW1000

Challenger007
Fresh Boarder
Fresh Boarder
Posts: 10
Joined: Thu Feb 04, 2021 5:07 pm

Re: Samba shares no longer available after Win10 update (fixed)

Post by Challenger007 »

Thanks for the link. By the way, not only with meteohub this problem I also got errors in other fairly old programs. Apparently, the problem is with the compatibility of the program code. Still, programming is moving forward and some outdated things simply stop working correctly.

Post Reply