CWOP stopped uploads after upgrade 5.0t

Discussion of the Meteohub software package

Moderator: Mattk

Post Reply
steved28
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Thu Mar 02, 2017 4:38 pm

CWOP stopped uploads after upgrade 5.0t

Post by steved28 » Thu Mar 02, 2017 5:06 pm

I just auto updated to 5.0t and now am receiving errors in the log. Any ideas?

2017.03.02 08:21:40 log file cleared by user
2017.03.02 08:22:32 meteohub: weathernet: CWOP - timeout:
2017.03.02 08:27:20 meteohub: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 08:32:33 meteohub: weathernet: CWOP - timeout:
2017.03.02 08:37:26 meteohub: weathernet: CWOP - timeout: error socket open (1): cwop.fuller.net,
2017.03.02 08:42:30 meteohub: weathernet: CWOP - timeout: error socket open (1): cwop.fuller.net,
2017.03.02 08:47:19 meteohub: weathernet: CWOP - timeout:
2017.03.02 08:52:23 meteohub: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 08:57:22 meteohub: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 08:57:31 meteohub: weathernet: CWOP - timeout: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 09:02:27 meteohub: weathernet: CWOP - timeout: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 09:02:29 meteohub: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 09:12:19 meteohub: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 09:12:19 meteohub: weathernet: CWOP - timeout: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 09:22:18 meteohub: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 09:27:18 meteohub: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 09:32:18 meteohub: weathernet: CWOP - timeout:
2017.03.02 09:37:32 meteohub: weathernet: CWOP - timeout:
2017.03.02 09:42:15 meteohub: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 09:47:25 meteohub: weathernet: CWOP - timeout:
2017.03.02 09:52:20 meteohub: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 09:52:33 meteohub: weathernet: CWOP - timeout: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,
2017.03.02 09:57:29 meteohub: weathernet: CWOP - timeout:
2017.03.02 10:02:15 meteohub: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org,

User avatar
YJB
Platinum Boarder
Platinum Boarder
Posts: 387
Joined: Thu Feb 19, 2009 5:53 pm
Location: Venhuizen, Netherlands
Contact:

Re: CWOP stopped uploads after upgrade 5.0t

Post by YJB » Thu Mar 02, 2017 8:32 pm

Same here, but I don' think i's related to your upgrade. I did run this version already for a while, and my errors started yesterday.

Code: Select all

2017.03.01 09:07:27 meteoplug: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org, 
2017.03.01 09:07:29 meteoplug: weathernet: CWOP - timeout: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org, 
2017.03.01 09:12:32 meteoplug: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org, 
2017.03.01 09:12:35 meteoplug: weathernet: CWOP - timeout: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org, 
2017.03.01 09:17:27 meteoplug: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org, 
2017.03.01 09:17:29 meteoplug: weathernet: CWOP - timeout: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org, 
2017.03.01 09:22:37 meteoplug: weathernet: CWOP: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org, 
2017.03.01 09:22:42 meteoplug: weathernet: CWOP - timeout: error socket open (1): cwop.fuller.net, error socket open (1): cwop.tssg.org, 
I've dropped Phil an email to check if something is wrong on the CWOP side of things.

Ysbrand

steved28
Fresh Boarder
Fresh Boarder
Posts: 2
Joined: Thu Mar 02, 2017 4:38 pm

Re: CWOP stopped uploads after upgrade 5.0t

Post by steved28 » Thu Mar 02, 2017 9:35 pm

Thanks for the reply, my data is flowing again. I did see where this server was down for a while. (after I posted this)
I used this link; http://www.wxqa.com/checkservers2.html
I wish there was a method in meteohub to change CWOP servers, as I see most others were working fine.

User avatar
YJB
Platinum Boarder
Platinum Boarder
Posts: 387
Joined: Thu Feb 19, 2009 5:53 pm
Location: Venhuizen, Netherlands
Contact:

Re: CWOP stopped uploads after upgrade 5.0t

Post by YJB » Thu Mar 02, 2017 11:12 pm

Looks like mine resumed uploading as well.

Response from Phil in the meantime:
You should be point to cwop.aprs.net on port 14580
Boris, can you check that this has been implemented in the code in a proper way?

Danke,
Ysbrand

User avatar
YJB
Platinum Boarder
Platinum Boarder
Posts: 387
Joined: Thu Feb 19, 2009 5:53 pm
Location: Venhuizen, Netherlands
Contact:

Re: CWOP stopped uploads after upgrade 5.0t

Post by YJB » Fri Mar 03, 2017 3:10 pm

Checked again with Phil, and it seems that all MH users were basically impacted.

The correct server to be used for CWOP data is documented in the following link

http://www.wxqa.com/servers2use.html
2. What server should I use if my packet ID is CWxxxx or DWxxxx or EWxxxx or FWxxxx?
- Use a server designator of "cwop.aprs.net" to send to servers (CWOP1, CWOP2, CWOP3, CWOP4) designated for CWOP non-ham use. These servers do not require a validation code or password.
There is no way that we can change the cwop server ourselves as it's hardcoded in /home/meteohub/meteonet

I've send Boris an email as well, so that he is aware.

Ysbrand

Post Reply