Meteohub no longer uploading Clientraw file

Moderator: Mattk

Post Reply
Heuer
Junior Boarder
Junior Boarder
Posts: 21
Joined: Wed Aug 18, 2010 2:32 pm

Meteohub no longer uploading Clientraw file

Post by Heuer » Wed Jul 20, 2016 3:54 pm

My plug has been working without problem for several years but a few days ago it stopped sending clientraw.txt files to my server.

I have checked it can connect and successfully ftp uploads the test file to the correct WDL directory. The local WDL console works and shows the latest data as does the dashboard. Data is being sent correctly and regularly to Weather Underground. FTP upload is activated but the files will not upload. The Davis Vantage Pro console shows all the correct data. If I manually move the latest clientraw files across to the server WDL displays the latest data. I have this message in the error log and email: 2016.07.19 17:37:19 meteoplug: weathernet: No data upload to weather networks as sensor selected on weather network page for outdoor temp, outdoor humidity or outdoor dewpoint is not providing recent data.: But this is the only message and I have email alterts for ftp failure set to 'immediate'

However I don't understand why given all the sensors are working correctly. Can anyone suggest a solution or, at least, some diagnostics I could run?

Thanks

David

Heuer
Junior Boarder
Junior Boarder
Posts: 21
Joined: Wed Aug 18, 2010 2:32 pm

Re: Meteohub no longer uploading Clientraw file

Post by Heuer » Thu Jul 21, 2016 11:57 am

Manually updated the software (was V4.9w) to latest version - still no upload. I am not getting any FTP failure emails either so it looks like Meteohub thinks the files are being sent correctly, but they are not on the web server.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5304
Joined: Mon Oct 01, 2007 10:51 pm

Re: Meteohub no longer uploading Clientraw file

Post by admin » Sun Jul 24, 2016 4:58 pm

Does log file "meteohub log" on "Log Files" page show any error messages?

Heuer
Junior Boarder
Junior Boarder
Posts: 21
Joined: Wed Aug 18, 2010 2:32 pm

Re: Meteohub no longer uploading Clientraw file

Post by Heuer » Wed Jul 27, 2016 5:15 pm

File erased by init script to save storage (data partition was 100% filled)
logger (01.01.2000 00:00:29): System date not properly set. Please set date and time correctly before data logging can start.
logger (24.07.2016 00:02:20): data logger (version 5.0q, build 1628) started.
logger (24.07.2016 00:02:21): connect station 0 (Vantage via USB serial).
logger (24.07.2016 00:02:21): station 0 (Vantage), wakeup sent.
logger (24.07.2016 00:02:21): station 0 (Vantage), internal logger activated.
logger (24.07.2016 00:02:21): station 0 (Vantage), syncing.
logger (24.07.2016 00:02:31): station 0 (Vantage), gettime request sent.
logger (24.07.2016 00:02:31): station 0 (Vantage), time offset of Vantage: 22 minutes
logger (24.07.2016 00:02:31): station 0 (Vantage), eeprom request sent.
logger (24.07.2016 00:02:31): station 0 (Vantage), rain collector size 0.01 inch per tick.
logger (24.07.2016 00:02:31): station 0 (Vantage), transmitter 1 active as station type (#0) "ISS".
logger (24.07.2016 00:02:31): station 0 (Vantage), transmitter 2 active as station type (#4) "Wind".
logger (24.07.2016 00:02:31): station 0 (Vantage), firmware version request sent.
logger (24.07.2016 00:02:47): station 0 (Vantage), no firmware version returned.
logger (24.07.2016 00:02:47): station 0 (Vantage), no reading of Vantage's internal logger as data gap is less than 10 minutes: 274 secs

Heuer
Junior Boarder
Junior Boarder
Posts: 21
Joined: Wed Aug 18, 2010 2:32 pm

Re: Meteohub no longer uploading Clientraw file

Post by Heuer » Sat Jul 30, 2016 6:05 pm

With help from one of the guys over on the Weather Display forum I finally managed to solve this. For future reference:

If you use an ftp password with special characters in it (* @ ) the 'Save and Test' function within Meteohub will successfully log on and upload the test file to the server. However the normal upload uses Cron in the format ftp://username:password@hostname/ and that does not allow special characters. As a result the upload fails but Meteohub does not produce an error report or give any indication there is a problem. Solution - use a password with no special characters.

Maybe a test can be included in a future version?

User avatar
Wessel
Senior Boarder
Senior Boarder
Posts: 41
Joined: Fri May 06, 2011 1:14 am

Re: Meteohub no longer uploading Clientraw file

Post by Wessel » Thu Jan 05, 2017 5:11 pm

My case is the same, the only difference is that I migrated from an old SD card to a new one and bigger (Data was full). Configuration is the same, nothing changed (even user/password of FTP), however is not uploading Clientraw and others files. Weather networks are working fine. Is there some relation with time? My console is with regular time and meteohub system is with summer time (automatically). But, the time was like this before I change the SD card too and everything was working.

User avatar
Wessel
Senior Boarder
Senior Boarder
Posts: 41
Joined: Fri May 06, 2011 1:14 am

Re: Meteohub no longer uploading Clientraw file

Post by Wessel » Thu Jan 05, 2017 7:47 pm

Wessel wrote:My case is the same, the only difference is that I migrated from an old SD card to a new one and bigger (Data was full). Configuration is the same, nothing changed (even user/password of FTP), however is not uploading Clientraw and others files. Weather networks are working fine. Is there some relation with time? My console is with regular time and meteohub system is with summer time (automatically). But, the time was like this before I change the SD card too and everything was working.
Solved. I just created all graphs again in "graph uploads". Now is working again.

Post Reply