Rainfall and Wind Gust Data Issues

Moderator: Mattk

Post Reply
mike88ag
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Sun Aug 14, 2016 3:53 am

Rainfall and Wind Gust Data Issues

Post by mike88ag » Wed Aug 17, 2016 4:01 pm

A few days ago it started raining heavily, and while the rainfall was registering on my VantagePro display, it was not being sent to Weather Underground or CWOP. I used the browser interface to reboot Meteohub and the missing rainfall was sent as a single total. It worked for approximately one hour before behaving the same way again. This time I unplugged the SheevaPlug, waited 15 seconds, and plugged it back in. It worked fine for a few days before I noticed it was acting up again. This time the problem began just before midnight, and after midnight the prior day's rainfall was not set to 0", but for some reason showed 0.08" (which was still less than the prior day's total). Later in the day we received 0.53" of rainfall, but the amount reported to Weather Underground was 0.61" (the bogus 0.08 plus the actual 0.53"). A little while later the precipitation total value in the data table declined to 0.53", but the daily summary table still showed 0.61". Before going to bed last night I once again power cycled the SheevaPlug, and although it seemed to start working again, I woke up this morning and saw that Weather Underground data table showed a total of 52" of rainfall yesterday (although the daily summary still showed 0.61")! The bad values started showing up after I powered it back up. The total reset to zero at midnight and it seems to be working for now.

One other thing I noticed is that this issue is also affecting wind gust data. whenever it is acting up, both the rain rate and wind gust fields show "--" in the data table...like the data isn't being sent at all. When it is working correctly, both fields show "0" if the wind is calm and it is not raining.

Could this have something to do with the most recent update? What about the memory card? I've been using this for several years and have never transferred data from the memory card, so it could be reaching its capacity. Do any issues result from the card being full, or does Meteohub simply overwrite the older data?

Post Reply