Problems accessing meteohub page **solved**

all about Meteohub on the new Raspberry PI platform

Moderator: Mattk

Post Reply
efiten
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Sun May 31, 2015 5:59 pm

Problems accessing meteohub page **solved**

Post by efiten » Fri Jul 06, 2018 12:15 pm

SInce a few days i can't access the webpage from the metehub anymore.

I get the login screen, where I fill in the details, next, it redirects to '/cgi-bin/meteohub.cgi' , but that's it.

Image

Already tried to reboot.
is there a way to see what's wrong ? The system itself is working, it sends his data to the different weather services.

Or is there a way to update the environlment from commandline, or backup from commandline.
Then I can copy this info, and re-install the complete system.

Erwin

mikeo
Fresh Boarder
Fresh Boarder
Posts: 12
Joined: Thu Jan 07, 2016 11:03 pm

Re: Problems accessing meteohub page

Post by mikeo » Fri Jul 06, 2018 8:37 pm

I'm having the exact same issue also on a Raspberry Pi. I don't know exactly when it started, and the data is still being uploaded. A reboot didn't help; I can SSH in, but I'm not quite sure what I should do from there. It's obvious the webserver is running, however everything appear to take place via cgi scripting.

mikeo
Fresh Boarder
Fresh Boarder
Posts: 12
Joined: Thu Jan 07, 2016 11:03 pm

Re: Problems accessing meteohub page

Post by mikeo » Fri Jul 06, 2018 8:45 pm

Looking around at other topics on this board, it appears that this is a common issue that started recently. We can only hope that Boris is aware and can provide a status update sometime soon.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5285
Joined: Mon Oct 01, 2007 10:51 pm

Re: Problems accessing meteohub page

Post by admin » Fri Jul 06, 2018 11:23 pm

I am not aware anything changed on our end. I just tested my Meteohub on RPI3 and the web interface works fine.

Can one of you please give me remote access, so that I can drill down to the issue?
Please send credentials to "info(at)meteohub.de".

User avatar
cbhiii
Gold Boarder
Gold Boarder
Posts: 306
Joined: Fri Feb 15, 2008 2:02 am
Location: Michigan, USA
Contact:

Re: Problems accessing meteohub page

Post by cbhiii » Sat Jul 07, 2018 12:09 am

I was having the same issue where I cannot access the menu using the local IP address on my own network, but it does seem to intermittently work when I use an external address and use port forwarding from my router.

It is strange because it seems like the first menu item "System Info" is the one that is taking the longest to load.

I have emailed my login information.
Last edited by cbhiii on Sat Jul 07, 2018 12:15 am, edited 1 time in total.
Station: Davis Vantage Pro2 Plus
Hardware: Raspberry Pi 2 (Meteohub status)

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5285
Joined: Mon Oct 01, 2007 10:51 pm

Re: Problems accessing meteohub page

Post by admin » Sat Jul 07, 2018 12:15 am

As it requests WANIP when starting with building system page, it is expected that this takes a moment. So this would not make me wonder.
When it can be reached from outside via port forwarding but not from within the LAN that is very strange as both is "external" IP traffic in the LAN. How should Meteohub notice any difference? Might more be a coincidence than causality?

efiten
Fresh Boarder
Fresh Boarder
Posts: 11
Joined: Sun May 31, 2015 5:59 pm

Re: Problems accessing meteohub page

Post by efiten » Sat Jul 07, 2018 12:16 am

admin wrote:
Fri Jul 06, 2018 11:23 pm
I am not aware anything changed on our end. I just tested my Meteohub on RPI3 and the web interface works fine.

Can one of you please give me remote access, so that I can drill down to the issue?
Please send credentials to "info(at)meteohub.de".
info sent via mail & PM


Erwin

User avatar
cbhiii
Gold Boarder
Gold Boarder
Posts: 306
Joined: Fri Feb 15, 2008 2:02 am
Location: Michigan, USA
Contact:

Re: Problems accessing meteohub page

Post by cbhiii » Sat Jul 07, 2018 12:17 am

I agree that external should be no different. In fact, the external is not working right now the last time I tried it.

I captured log data from the menus when I had access earlier, but i didn't see anything wrong.

Maybe trying SSH could work.
Station: Davis Vantage Pro2 Plus
Hardware: Raspberry Pi 2 (Meteohub status)

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5285
Joined: Mon Oct 01, 2007 10:51 pm

Re: Problems accessing meteohub page

Post by admin » Sat Jul 07, 2018 1:49 am

you should be all fine again :-)

User avatar
cbhiii
Gold Boarder
Gold Boarder
Posts: 306
Joined: Fri Feb 15, 2008 2:02 am
Location: Michigan, USA
Contact:

Re: Problems accessing meteohub page

Post by cbhiii » Sat Jul 07, 2018 1:56 am

Great! Thank you!

I see I'm now on 5.0y. It this the fix? :D
Station: Davis Vantage Pro2 Plus
Hardware: Raspberry Pi 2 (Meteohub status)

JeroenZwart
Fresh Boarder
Fresh Boarder
Posts: 12
Joined: Wed Jul 04, 2018 9:43 pm

Re: Problems accessing meteohub page

Post by JeroenZwart » Sat Jul 07, 2018 8:06 am

I have got the same problem: I can't login to MB any more... Can you please help?

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5285
Joined: Mon Oct 01, 2007 10:51 pm

Re: Problems accessing meteohub page

Post by admin » Sat Jul 07, 2018 8:36 am

This is about slow response of the Meteohub start screen. Meteobridge is covered elsewhere in the forum.

Post Reply