Lost settings.

All about the standard Meteobridge devices based on mobile routers from TP-Link, D-Link, ASUS

Moderator: Mattk

Post Reply
User avatar
ConligWX
Junior Boarder
Junior Boarder
Posts: 28
Joined: Wed Nov 14, 2018 12:48 pm
Location: Conlig, Co. Down, UK
Contact:

Lost settings.

Post by ConligWX » Sat Dec 08, 2018 3:29 pm

Not sure why, but I was in the admin panel of Metoebridge nano sd, just check settings etc. and changed a couple of parameters.

then about couple of minutes later I check the Weather Nets tab, and most of the settings have either gone or are blank.

Services: every service has gone. I had about 10-12 entries. ALL gone.

I have about 8 backups. all restore, but the weather nets and services are not restored, so what does the backup actually backup? surely the backup would backup services and weather Nets settings?

I just can not believe I have to manually enter everything again.

I suggest to everyone write down all your weather net entries and services down so if this happens to you, your not inconvenienced like I am now.

it looks like the backup.sh does not backup the meteobridge configuration, that i expected it to be.

lesson learnt - the hardway.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5479
Joined: Mon Oct 01, 2007 10:51 pm

Re: Lost settings.

Post by admin » Sat Dec 08, 2018 3:53 pm

settings are stored with "backup button" at "configuration data" line on "System" tab.

Screenshot 2018-12-08 at 14.52.07.png
Screenshot 2018-12-08 at 14.52.07.png (21.9 KiB) Viewed 70 times

I have no idea, why your settings are lost. When you can reproduce this, I might be able to track what is going wrong.

User avatar
ConligWX
Junior Boarder
Junior Boarder
Posts: 28
Joined: Wed Nov 14, 2018 12:48 pm
Location: Conlig, Co. Down, UK
Contact:

Re: Lost settings.

Post by ConligWX » Sat Dec 08, 2018 4:14 pm

is there anyway of automating the backup of the configuration?

User avatar
ConligWX
Junior Boarder
Junior Boarder
Posts: 28
Joined: Wed Nov 14, 2018 12:48 pm
Location: Conlig, Co. Down, UK
Contact:

Re: Lost settings.

Post by ConligWX » Sat Dec 08, 2018 5:18 pm

backup taken and all running again.

I shall know next time i'm in the control panel. take a backup, check the backup file contents, before altering anything.

Mattk
Platinum Boarder
Platinum Boarder
Posts: 558
Joined: Mon Sep 22, 2014 3:24 am

Re: Lost settings.

Post by Mattk » Sat Dec 08, 2018 9:54 pm

ConligWX wrote:
Sat Dec 08, 2018 5:18 pm
backup taken and all running again.

I shall know next time i'm in the control panel. take a backup, check the backup file contents, before altering anything.
That should be a common practice with changes/modifications with any system, very good habit to get into.

Automating the backup, maybe have a look at "Automated Backups" in the Push services link https://www.meteobridge.com/wiki/index. ... h_Services

User avatar
ConligWX
Junior Boarder
Junior Boarder
Posts: 28
Joined: Wed Nov 14, 2018 12:48 pm
Location: Conlig, Co. Down, UK
Contact:

Re: Lost settings.

Post by ConligWX » Sat Dec 08, 2018 11:59 pm

Yes, I had set that already. It doesn't backup the configuration data. Hense the initial post.

It looks like you can only automate backup of the database maintenance not the configuration backup as I already tried restoring that and the settings were not restored as I lost services or missing weather nets, these were not restored from the automated backup (backup.sh)

You must manually backup configuration data and store it always from the meteobride

Mattk
Platinum Boarder
Platinum Boarder
Posts: 558
Joined: Mon Sep 22, 2014 3:24 am

Re: Lost settings.

Post by Mattk » Sun Dec 09, 2018 10:59 am

Ok in that regard why would you want to automate the config backup anyway? It's not like the config really changes that much, simple practice is after any config change (or also before for that matter) then create a backup, the config does not change by itself.

User avatar
ConligWX
Junior Boarder
Junior Boarder
Posts: 28
Joined: Wed Nov 14, 2018 12:48 pm
Location: Conlig, Co. Down, UK
Contact:

Re: Lost settings.

Post by ConligWX » Sun Dec 09, 2018 1:06 pm

Why? To improve what is already there. Simple......

Post Reply