TP-Link TL-MR3020 v3 not logging from W-8681-PRO II

All about the standard Meteobridge devices based on mobile routers from TP-Link, D-Link, ASUS

Moderator: Mattk

Post Reply
weather@eggbox.uk
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Thu Jan 09, 2020 11:49 am

TP-Link TL-MR3020 v3 not logging from W-8681-PRO II

Post by weather@eggbox.uk » Thu Jan 09, 2020 12:08 pm

Hello,

i have a TP-Link TL-MR3020 v3 connected to a W-8681-PRO II and i'm getting the error below,
"Data logger does not provide data. Please check that station settings are correct."

i have reset the system and it still will not log the data.

please find the logs below, any help gratefully received.

wnetd (09.01.2020 09:37:50): process started.
system (09.01.2020 09:37:50): start of logging process initiated.
logger (09.01.2020 09:37:51): Free trial period will end in 14 days. When you want to use this device beyond that period, you are welcome to use online licensing feature on "License" tab to purchase a license.
logger (09.01.2020 09:37:51): no historical data loaded.
logger (09.01.2020 09:37:51): data logger (version 5.1c, build 2777) started.
logger (09.01.2020 09:37:55): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (09.01.2020 09:37:55): services paused.
system (09.01.2020 09:38:41): stop of logging process initiated.
logger (09.01.2020 09:38:41): parent process received termination signal (15).
logger (09.01.2020 09:38:41): child process received termination signal (15).
system (09.01.2020 09:38:41): start of logging process initiated.
logger (09.01.2020 09:38:42): Free trial period will end in 14 days. When you want to use this device beyond that period, you are welcome to use online licensing feature on "License" tab to purchase a license.
logger (09.01.2020 09:38:42): no historical data loaded.
logger (09.01.2020 09:38:42): data logger (version 5.1c, build 2777) started.
logger (09.01.2020 09:38:43): connect station 0 (WH-1080/3080 via USB HID).
logger (09.01.2020 09:38:46): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (09.01.2020 09:38:46): services paused.
system (09.01.2020 09:39:02): stop of logging process initiated.
system (09.01.2020 09:39:08): start of logging process initiated.
logger (09.01.2020 09:39:09): Free trial period will end in 14 days. When you want to use this device beyond that period, you are welcome to use online licensing feature on "License" tab to purchase a license.
logger (09.01.2020 09:39:09): no historical data loaded.
logger (09.01.2020 09:39:09): data logger (version 5.1c, build 2777) started.
logger (09.01.2020 09:39:10): connect station 0 (WH-1080/3080 via USB HID).
logger (09.01.2020 09:39:13): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (09.01.2020 09:39:13): services paused.
logger (09.01.2020 09:41:10): give up waiting for sensors after 120 secs.
logger (09.01.2020 09:41:10): services activated.
logger (09.01.2020 09:43:19): error while waiting for data from weather stations
logger (09.01.2020 09:49:40): child process received timeout signal (14).
logger (09.01.2020 09:49:40): child process received termination signal (11) in functions: termination_handler < close_serial < myexit < alarm_handler < put_set < put_set_name_value < g...
logger (09.01.2020 09:49:40): no historical data loaded.
logger (09.01.2020 09:49:40): data logger (version 5.1c, build 2777) started.
logger (09.01.2020 09:49:40): error (22) while doing bind (port 5551): Invalid argument
logger (09.01.2020 09:49:40): killed process "2798/sh" listening to port 5551.
logger (09.01.2020 09:49:40): killed process "2799/hidlog6" listening to port 5552.
logger (09.01.2020 09:49:41): data logger stopped.
logger (09.01.2020 09:50:10): no historical data loaded.
logger (09.01.2020 09:50:10): data logger (version 5.1c, build 2777) started.
logger (09.01.2020 09:50:11): connect station 0 (WH-1080/3080 via USB HID).
logger (09.01.2020 09:50:14): waiting for sensors (wind0, rain0, th0, thb0) to provide data.
logger (09.01.2020 09:50:14): services paused.
logger (09.01.2020 09:52:11): give up waiting for sensors after 120 secs.
logger (09.01.2020 09:52:11): services activated.
logger (09.01.2020 10:00:41): child process received timeout signal (14).

thanks,

Martin

weatherist34
Gold Boarder
Gold Boarder
Posts: 297
Joined: Tue Mar 28, 2017 6:57 am
Contact:

Re: TP-Link TL-MR3020 v3 not logging from W-8681-PRO II

Post by weatherist34 » Thu Jan 09, 2020 12:22 pm

i seem to recall i had a similar model a few years ago branded from maplins, watson was a branded version for a store called waters and stanton in the uk which has now ceased trading .it needed a meteostick and unless something changed in the design you would need mr3020 with the additional meteostick.
https://www.meteobridge.com/wiki/index.php/Stations

more info https://www.meteobridge.com/wiki/index.php/Stations note your station is or was branded under various names but ultimately is was more known as a ws1001
scroll down to meteostick section .not owning one anymore im not familiar with the newer bridge offerings for this type of station.

just confirm is this what you have
https://www.amazon.co.uk/W-8681-PRO-WEA ... B01ATP0HNK

weather@eggbox.uk
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Thu Jan 09, 2020 11:49 am

Re: TP-Link TL-MR3020 v3 not logging from W-8681-PRO II

Post by weather@eggbox.uk » Thu Jan 09, 2020 1:02 pm

Thanks for the info weatherist34, yes that's the one.

will be cheaper to buy a station that is supported.

weatherist34
Gold Boarder
Gold Boarder
Posts: 297
Joined: Tue Mar 28, 2017 6:57 am
Contact:

Re: TP-Link TL-MR3020 v3 not logging from W-8681-PRO II

Post by weatherist34 » Thu Jan 09, 2020 2:23 pm

yes I think so that model is out of date for those that want to do a bit more or share there data in various ways to other sites or your own. there are hacks for it to do other things like that at firmware level but if buying a more upto date station is feasible I would take that path.however do your homework on what you want to achieve that model will serve for a while its not very durable but in a UK climate might fair better than the strong summer UV we get here in istanbul which absolutely decimated the plastic chasis and wind vane it turned yellow with in 3 months :-( . if you just want to see that data on the console it came with then it will do its job until fails.

all to easy to get confused by the vast offerings so I wouldn't jump until you done your homework and it can be a bit confusing . your lucky in the UK there are dedicated hardware resellers like https://weatherspares.co.uk Adrian he is really a nice guy and reachable he is not a robot sitting on end of email he is human and probably can put you in the right direction and of course you have a valid warranty and backup if things go wrong at the touch of a phone call ..

User avatar
galfert
Expert Boarder
Expert Boarder
Posts: 90
Joined: Sun Jun 24, 2018 10:31 pm
Location: Orlando, FL

Re: TP-Link TL-MR3020 v3 not logging from W-8681-PRO II

Post by galfert » Sat Jan 11, 2020 2:44 pm

That station console is not supported by Meteobridge. Instead of buying a complete new station you could instead get an Ecowitt GW1000. That will pick up all the sensors you have (and even newer sensors) and it will interface with Meteobridge. Be sure to select WH24 as station type when setting up the GW1000. Of course a newer station will provide better results as newer sensors are better. But the GW1000 gets you by for now and the investment is worth it because even a newer station today benefits from having the GW1000. Order the GW1000 directly from Ecowitt and be sure to match the frequency when ordering to your current W-8681. The GW1000 comes in three different ways 433, 868, and 915 MHz. Find out what frequency your W-8681 uses.
MR3020 v1
GW1000

weather@eggbox.uk
Fresh Boarder
Fresh Boarder
Posts: 3
Joined: Thu Jan 09, 2020 11:49 am

Re: TP-Link TL-MR3020 v3 not logging from W-8681-PRO II

Post by weather@eggbox.uk » Sun Jan 12, 2020 7:05 pm

Thanks galfert,

Post Reply