Local Dashboard updates stop on Nano SD

This section covers the Meteobridge PRO units exclusively

Moderator: Mattk

Post Reply
rks
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: Mon Jun 03, 2019 9:28 pm

Local Dashboard updates stop on Nano SD

Post by rks » Wed Mar 11, 2020 11:20 pm

Updates to the Local Dashboard stop randomly after a few hours or days following a reboot. The problem is indicated by the weather network status on the live data page which shows a green tick but the time of the last update does not change. The two external weather services in the Local Dashboard (Darksky and CheckWX) show the time of the last update and offline. Weather Underground updates also fail causing the buffer to fill to 100%. In both cases update requests are set to 1 minute and rebooting always starts normal updating but they eventually stop. I use a Davis Vantage VP 2 and a Nano SD, both 10 months old. This is a recent problem, in the past the system has run for over 100 days with no reboot. Now it’s every 2 or 3 days at most. I have reliable network links and all other Meteobridge functions I use continue to work well. Any suggestions as to the problem?

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 6048
Joined: Mon Oct 01, 2007 10:51 pm

Re: Local Dashboard updates stop on Nano SD

Post by admin » Sat Mar 14, 2020 11:50 am

Do you have additional batteries in the console? Which mA rating does the console power supply have?

rks
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks » Fri Mar 20, 2020 8:29 pm

Apologies for delay in replying. I have new alkaline batteries fitted and the Davis psu is rated at 1 amp.

rks
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks » Mon Mar 23, 2020 11:09 pm

Following a reply to an apparently similar problem in the Meteobridge discussion I swapped the Davis 1 amp supply for an uprated 2 amp supply. Unfortunately the problem reoccurred within 2 days with both the Local Dashboard and Weather Underground enabled. Rebooting cleared the problem. Note that the internet was running despite the WLAN IP indicating there was ‘no internet’. I suggest that this might be a clue to the update problem possibly the Nano SD is losing the internet connection for some reason.
1546018A-E5AC-4BBD-B6B5-B2D09B3A4F99.png
System page at failure.
1546018A-E5AC-4BBD-B6B5-B2D09B3A4F99.png (489.03 KiB) Viewed 177 times

ToTo
Senior Boarder
Senior Boarder
Posts: 77
Joined: Wed Apr 03, 2019 9:24 am

Re: Local Dashboard updates stop on Nano SD

Post by ToTo » Tue Mar 24, 2020 3:15 pm

I had similar problems with the Wlan connection. Set the wifi channel in the router fix and not automatically. Also change the used channel if there are further problems.

This helped me.
PWS Magdeburg - Germany - https://wetter.de.cool/console

rks
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks » Tue Mar 24, 2020 6:38 pm

Thanks ToTo, I’ll set up a fixed link, as you suggest. I already have the address reserved in the router. I appreciate your help.

rks
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks » Sat Mar 28, 2020 10:48 pm

I have applied manual ip addresses, fixed channel 7 on the router as suggested by members and still the updates stopped, as can be seen from the attachments. The wifi signal is good and the WLAN is working. This had not used to happen when I first used Nano SD in May 2019. It is not possible to support Weather Underground or even local dashboard as it stands. Could the problem be the use of a wifi repeater, hence the two wistaria_2.4 signals?
1F818F2A-6AE5-4CC5-9A0D-5B4ADAA343B2.png
Good signal and manual ip
1F818F2A-6AE5-4CC5-9A0D-5B4ADAA343B2.png (286.37 KiB) Viewed 70 times
Attachments
A6C1FDCE-5743-452C-96C7-769A6A2B81AC.png
No updates 3 hours, why has it stopped?
A6C1FDCE-5743-452C-96C7-769A6A2B81AC.png (466.8 KiB) Viewed 70 times
6D475A42-0451-49A8-BE49-129A4FE80AFA.png
Buffer filling. WLAN connected
6D475A42-0451-49A8-BE49-129A4FE80AFA.png (463.33 KiB) Viewed 70 times

ToTo
Senior Boarder
Senior Boarder
Posts: 77
Joined: Wed Apr 03, 2019 9:24 am

Re: Local Dashboard updates stop on Nano SD

Post by ToTo » Sun Mar 29, 2020 10:47 am

Too bad that the idea of finding a solution did not help. Can you see in your router, how strong is the Wlan connection to the NanaoSD? Maybe change the position and distance to the router?
PWS Magdeburg - Germany - https://wetter.de.cool/console

rks
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: Mon Jun 03, 2019 9:28 pm

Re: Local Dashboard updates stop on Nano SD

Post by rks » Sun Mar 29, 2020 5:57 pm

Agreed ToTo, but as I show in the network screen shot the Nano card ‘sees’ two router signals, one from the router directly (7%) and one from the repeater (99%). I assume the best signal is used but maybe it connects to the weaker signal on occasions causing problems. I’ve set to the router to avoid channel hopping at channel 7 as suggested elsewhere. My only other thought is to turn the repeater off and move the Davis Pro2 to a location with a better direct signal from the router and see if that cures the problem in the short term. However, the location would be unsatisfactory long term. Moving the router is not an option, after all that’s why we have repeaters.

Post Reply