Search found 87 matches

by staze
Fri Sep 20, 2019 12:09 am
Forum: Meteobridge Discussion
Topic: Random Station Disconnect (Nano SD)
Replies: 3
Views: 26

Re: Random Station Disconnect (Nano SD)

Soft reboot of Nano SD fixed it. So I wouldn't think it's the envoy or the VSS. Seems more like the Nano just dropped the connection for some reason.

Is there anything I can look at if it happens again to help figure out WHY?
by staze
Thu Sep 19, 2019 4:58 am
Forum: Meteobridge Discussion
Topic: Random Station Disconnect (Nano SD)
Replies: 3
Views: 26

Random Station Disconnect (Nano SD)

Just had my Nano SD, which is in an Envoy, report "Station Disconnect 0 (Vantage)". Never had this happen before. Thankfully Weathercat told me about it (saying station data hadn't changed in 12 minutes). Any idea why this would have happened? Anything I should investigate? I lost it, but I think I ...
by staze
Tue Sep 10, 2019 4:15 pm
Forum: Meteobridge Discussion
Topic: APIXU -> Weatherstack
Replies: 0
Views: 50

APIXU -> Weatherstack

Hi all, Anyone else get this email? Sounds like API changes needed. [Action Required] Your Apixu Account Dear Apixu User, Great News: Apixu is now weatherstack After months of preparation, Apixu is now officially relaunching as weatherstack - a new, faster, more capable and completely rebuilt weathe...
by staze
Sat Aug 31, 2019 6:38 pm
Forum: Meteobridge Discussion
Topic: Template causes MB lockup on 3.9 & 4.0 - works fine on 3.8 **solved**
Replies: 24
Views: 780

Re: Template causes MB lockup on 3.9 & 4.0 - works fine on 3.8 **solved**

Been up and running consistently (no reboots on either end) for several days now. Haven't seen a single 50x error.

Thanks Boris for making this change! =)
by staze
Thu Aug 29, 2019 12:49 am
Forum: Meteobridge Discussion
Topic: Template causes MB lockup on 3.9 & 4.0 - works fine on 3.8 **solved**
Replies: 24
Views: 780

Re: Template causes MB lockup on 3.9 & 4.0 - works fine on 3.8

@staze - Although I don't believe that the MeteoBridge is single-threaded, 33 requests each taking 8+ seconds eventually has multiple requests being handled simultaneously, and apparently a large percentage of those have to go through the CGI Template responder. At some point something has to give....
by staze
Wed Aug 28, 2019 10:28 pm
Forum: Meteobridge Discussion
Topic: Template causes MB lockup on 3.9 & 4.0 - works fine on 3.8 **solved**
Replies: 24
Views: 780

Re: Template causes MB lockup on 3.9 & 4.0 - works fine on 3.8

I wonder why we'd enter this state at all... why is MB suddenly unable to, seemingly reliably, respond to these requests after some number of hours...
by staze
Wed Aug 28, 2019 6:54 pm
Forum: Meteobridge Discussion
Topic: Template causes MB lockup on 3.9 & 4.0 - works fine on 3.8 **solved**
Replies: 24
Views: 780

Re: Template causes MB lockup on 3.9 & 4.0 - works fine on 3.8

I'm like sandood, and using a MB Nano SD. Also using his code (Hubitat or ST grabbing from the MB). Let me ping him and see if he can answer the query question more authoritatively.
by staze
Wed Aug 28, 2019 3:01 am
Forum: Meteobridge Discussion
Topic: Template causes MB lockup on 3.9 & 4.0 - works fine on 3.8 **solved**
Replies: 24
Views: 780

Re: Template causes MB lockup on 3.9 & 4.0 - works fine on 3.8

I'm seeing same issue. 4.1 seems to persist with this issue.

Reverting back to 3.8 for now... =(
by staze
Mon Apr 22, 2019 8:15 pm
Forum: Meteobridge PRO Discussion
Topic: Data Import function for MB PRO and NANO SD
Replies: 104
Views: 5162

Re: Data Import function for MB PRO and NANO SD

yay!

And yeah, it's not terribly clear. I spent a good couple days on fixing my data for MB, so glad I could share that knowledge rather than it just being lost. =)

Take care! And be patient. MB takes a while to import data (I think my 10ish years of data took about 16 hours to import).
by staze
Mon Apr 22, 2019 6:54 pm
Forum: Meteobridge PRO Discussion
Topic: Data Import function for MB PRO and NANO SD
Replies: 104
Views: 5162

Re: Data Import function for MB PRO and NANO SD

oh. yes, that's the issue. You want to go into the MT control panel, and under "Backup" just select "All" or a specific year and "OK". It should download a database export. At that point, all you should need to do (since you're already on ISO units) is change the solar radiation field to 0 rather th...
by staze
Mon Apr 22, 2019 5:57 pm
Forum: Meteobridge PRO Discussion
Topic: Data Import function for MB PRO and NANO SD
Replies: 104
Views: 5162

Re: Data Import function for MB PRO and NANO SD

Okay, there's a lot here that's not going to work. First, you have semicolons instead of commas. Second, you have the date/time separated out from eachother. Did this file come directly from MT? The columns also seem mixed up. From MT 17.1 (latest version) my columns are: 0 DateTime Date and Time 1 ...
by staze
Mon Apr 22, 2019 4:00 pm
Forum: Meteobridge PRO Discussion
Topic: Data Import function for MB PRO and NANO SD
Replies: 104
Views: 5162

Re: Data Import function for MB PRO and NANO SD

Hi Leon, As offered, I’m happy to take a look at your MT export and adjust for import into MB. I believe the list of variables is identical in order to the MT database table. But MB needs all of them, you cannot delete columns that you don’t want/need. Like the solar radiation column. Your screensho...
by staze
Sat Apr 20, 2019 2:59 am
Forum: Meteobridge Discussion
Topic: Upload to meteotemplate
Replies: 24
Views: 1102

Re: Upload to meteotemplate

Moved table back to it's own DB (I had consolidated wondering if that was an issue), and converted back to MyISAM. That resolved the issue. Can I implore you to please, add a true primary key column (ID or something), set it to autoincrement, and then just index on datetime (and set to unique) rathe...
by staze
Sat Apr 20, 2019 2:27 am
Forum: Meteobridge Discussion
Topic: Upload to meteotemplate
Replies: 24
Views: 1102

Re: Upload to meteotemplate

not that I know of, but I have been meaning to see if I can enable slow queries. That might show what's going on... might. again, the data gets inserted. and the API log from MT looks fine. either it's just not responding (and MB times out waiting for a response) or for some reason the insert is jus...
by staze
Sat Apr 20, 2019 2:05 am
Forum: Meteobridge Discussion
Topic: Upload to meteotemplate
Replies: 24
Views: 1102

Re: Upload to meteotemplate

That is so weird. It's only on the DB update times (the 5 minute intervals). But an insert should happen pretty quick (it's innodb, so there's no need to lock the table or the whole db). Weird. alright, will see if I can add some logging to see how long the insert is taking. I'm not entirely convinc...