Twitter Issues **solved**

This section covers the Meteobridge PRO units exclusively

Moderator: Mattk

Post Reply
Patrick_UK
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Sat May 04, 2019 5:03 pm

Twitter Issues **solved**

Post by Patrick_UK » Fri May 10, 2019 7:07 pm

Is anybody else experiencing issues posting to Twitter?
Some days it has worked at hourly intervals and other days it might post once or twice and then not again for days.

Live data tab shows successful transfer to Twitter every hour.

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5879
Joined: Mon Oct 01, 2007 10:51 pm

Re: Twitter Issues

Post by admin » Sat May 11, 2019 8:23 am

Are you running the latest meteobridge version?

weerwantijdijk
Senior Boarder
Senior Boarder
Posts: 40
Joined: Thu Jul 19, 2018 10:49 am
Location: Dordrecht, Netherlands
Contact:

Re: Twitter Issues

Post by weerwantijdijk » Sat May 11, 2019 12:21 pm

Twitter is working fine over here: hourly tweets are still getting launched at my timeline.
Image

Patrick_UK
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Sat May 04, 2019 5:03 pm

Re: Twitter Issues

Post by Patrick_UK » Sat May 11, 2019 3:10 pm

Yes running V4 the latest one.

User avatar
ConligWX
Gold Boarder
Gold Boarder
Posts: 214
Joined: Wed Nov 14, 2018 12:48 pm
Location: Conlig, Co. Down, UK
Contact:

Re: Twitter Issues

Post by ConligWX » Sun May 12, 2019 9:03 pm

twitter working fine here every hour. using 3.9 and v4 now. (NANOSD)

maybe DNS issue? what DNS IPs are you using?

Patrick_UK
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Sat May 04, 2019 5:03 pm

Re: Twitter Issues

Post by Patrick_UK » Sat May 18, 2019 11:56 am

Use the default BT hub ones.

Patrick_UK
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Sat May 04, 2019 5:03 pm

Re: Twitter Issues

Post by Patrick_UK » Sun May 19, 2019 8:45 am

Also I have noticed that if I do a hard power down, when it comes back up it then will post once or twice then stop again.

Patrick_UK
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Sat May 04, 2019 5:03 pm

Re: Twitter Issues

Post by Patrick_UK » Mon May 27, 2019 2:29 pm

Is there a way to see what the response is from Twitter, like in a log file?
As Live Data screen says successful but still not showing in the feed. Getting a new pin doesn't work either.
Tried deleting the service and restarting everything but still not working.

User avatar
ConligWX
Gold Boarder
Gold Boarder
Posts: 214
Joined: Wed Nov 14, 2018 12:48 pm
Location: Conlig, Co. Down, UK
Contact:

Re: Twitter Issues

Post by ConligWX » Tue May 28, 2019 12:00 am

you need to show what your posting ie
what message text is inside [ code ] [ / code]

This is mine:

Code: Select all

Time: [hh]:[mm] • Temp: [th0temp-act:--]°C • Wind: [wind0dir-act=endir:---] [wind0wind-act=mph.1:--] to [wind0wind-max10=mph.1:--]mph • Pressure: [thb0press-act:--]hPa • Rain: [rain0total-sumday]mm • Hum: [th0hum-act.0=:--]% • ET: [sol0evo-act.1=:--]mm • Solar: [sol0rad-act:--]W/m² • UV Index: [uv0index-act:--] • Sunrise: [mbsystem-sunrise:--] • Sunset: [mbsystem-sunset:--] • Cloudbase: #if#[th0temp-act.1:0.0]>[th0dew-act.1:0.0]#then#{*([th0temp-act.1:0.0]-[th0dew-act.1:0.0])*400*0}#else#0#fi#ft • #Conlig, #Bangor • bit.ly/2TzKYFb •

Patrick_UK
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Sat May 04, 2019 5:03 pm

Re: Twitter Issues

Post by Patrick_UK » Sat Jun 01, 2019 8:37 am

It is very similar to yours, I got from a template post on here. (yours I think) :)

Code: Select all

Time: [hh]:[mm] • Temp: [th0temp-act:--]°C • Wind: [wind0dir-act=endir:---] [wind0wind-act=mph.1:--] to [wind0wind-max10=mph.1:--]mph • Pressure: [thb0seapress-act:--]hPa • Rain: [rain0total-sumday]mm • Hum: [th0hum-act.0=:--]% • ET: [sol0evo-act.1=:--]mm • Solar: [sol0rad-act:--]W/m² • UV Index: [uv0index-act:--] • Sunrise: [mbsystem-sunrise:--] • Sunset: [mbsystem-sunset:--] • Cloudbase: #if#[th0temp-act.1:0.0]>[th0dew-act.1:0.0]#then#{*([th0temp-act.1:0.0]-[th0dew-act.1:0.0])*400*0}#else#0#fi#ft • [forecast-text] #Dunstable

Patrick_UK
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Sat May 04, 2019 5:03 pm

Re: Twitter Issues

Post by Patrick_UK » Sun Jun 09, 2019 12:10 pm

I have finally figured out the issue. It was to do with have [forecast-text] at the end, sometimes the forecast line pushes the tweet over the limit so it just doesn't post it. I thought twitter would cut off the extra characters but not!

User avatar
admin
Platinum Boarder
Platinum Boarder
Posts: 5879
Joined: Mon Oct 01, 2007 10:51 pm

Re: Twitter Issues

Post by admin » Sun Jun 09, 2019 5:32 pm

Thanks for letting us know. May be Meteobridge should cut the string? Is the limit you hit currently still 280?

User avatar
ConligWX
Gold Boarder
Gold Boarder
Posts: 214
Joined: Wed Nov 14, 2018 12:48 pm
Location: Conlig, Co. Down, UK
Contact:

Re: Twitter Issues

Post by ConligWX » Sun Jun 09, 2019 9:08 pm

Patrick_UK wrote:
Sun Jun 09, 2019 12:10 pm
I have finally figured out the issue. It was to do with have [forecast-text] at the end, sometimes the forecast line pushes the tweet over the limit so it just doesn't post it. I thought twitter would cut off the extra characters but not!
I created a separate entry for Weather Forecast which I post every 3 hours on twitter. so never experienced this issue.

Patrick_UK
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Sat May 04, 2019 5:03 pm

Re: Twitter Issues

Post by Patrick_UK » Thu Jun 13, 2019 1:25 pm

That is what I resorted to as a test, but have kept it now.

Patrick_UK
Fresh Boarder
Fresh Boarder
Posts: 9
Joined: Sat May 04, 2019 5:03 pm

Re: Twitter Issues

Post by Patrick_UK » Thu Jun 13, 2019 1:26 pm

admin wrote:
Sun Jun 09, 2019 5:32 pm
Thanks for letting us know. May be Meteobridge should cut the string? Is the limit you hit currently still 280?
Yes

Post Reply